Bug 152149 - gcc4 Segmentation fault building vim-6.3
Summary: gcc4 Segmentation fault building vim-6.3
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc4
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-25 11:45 UTC by Robert Connolly
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-03-25 21:03:44 UTC


Attachments (Terms of Use)
preprocessed os_unix.i (280.76 KB, text/plain)
2005-03-25 12:05 UTC, Robert Connolly
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 20640 None None None Never

Description Robert Connolly 2005-03-25 11:45:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
I'm not a redhat/fedora user, but I pulled the rhl_branch from gcc.gnu.org and 
I was building a system. Everything was well (perfect binutils testsuite, 
decent results from glibc and gcc testsuite) until I got to vim-6.3: 
 
gcc -c -I. -Iproto -DHAVE_CONFIG_H     -march=i686 -mtune=prescott 
-fomit-frame-pointer -funroll-loops -maccumulate-outgoing-args -O2 -pipe        
-o objects/os_unix.o os_unix.c 
os_unix.c: In function 'mch_settmode': 
os_unix.c:2697: internal compiler error: Segmentation fault 
 
Try building vim-6.3 with gcc-4.0.0, see what happens. 
 

Version-Release number of selected component (if applicable):
gcc version 4.0.0 20050323 (Red Hat 4.0.0-0.36)

How reproducible:
Always

Steps to Reproduce:
1. Compile vim with gcc4. 
2. 
3. 
   

Actual Results:  os_unix.c: In function 'mch_settmode': 
os_unix.c:2697: internal compiler error: Segmentation fault 
 

Expected Results:  No segmentation fault  

Additional info:

Comment 1 Jakub Jelinek 2005-03-25 11:54:32 UTC
Please provide preprocessed os_unix.i (rerun the above command with -save-temps).

Comment 2 Robert Connolly 2005-03-25 12:05:26 UTC
Created attachment 112345 [details]
preprocessed os_unix.i

This is the requested preprocessed os_unix.i, made with:

cd vim63/src &&
cc -c -I. -Iproto -DHAVE_CONFIG_H -march=i686 -mtune=prescott
-fomit-frame-pointer -funroll-loops -maccumulate-outgoing-args -O2 -o
objects/os_unix.o os_unix.c -save-temps

Comment 3 Robert Connolly 2005-03-25 12:08:05 UTC
This is caused by -funroll-loops. funroll-loops is fine with gcc-3.4.3 and 
this package. 


Note You need to log in before you can comment on or make changes to this bug.