This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 152155 - yum won't die on ctrl-C ^c signal 15
yum won't die on ctrl-C ^c signal 15
Status: CLOSED DUPLICATE of bug 139459
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-25 08:38 EST by Need Real Name
Modified: 2014-01-21 17:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-20 14:53:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-25 08:38:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Epiphany/1.4.4

Description of problem:
yum doesn't exit if I Ctrl-C it, instead it tries another mirror.
Fair enough, other programs do this.

It would be nice if yum died after a double Ctrl-C to match other programs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Albert Strasheim 2005-04-16 10:17:53 EDT
Alternatively, if you Ctrl-C more than once for the same mirror, abort.
Comment 2 Need Real Name 2005-04-19 09:05:11 EDT
> we've tracked it down - the problem with ctrl-c being grabbed
> is happening inside the python socketmodule
 -- https://www.redhat.com/archives/fedora-test-list/2005-April/msg01545.html

Reported upstream:
 http://sourceforge.net/tracker/index.php?func=detail&aid=1185931&group_id=5470&atid=105470

(My) upstream bug report is quite poor though.
Comment 3 Rahul Sundaram 2005-06-18 23:06:17 EDT

This is related to #139459
Comment 4 Rahul Sundaram 2005-06-20 14:53:55 EDT

*** This bug has been marked as a duplicate of 139459 ***

Note You need to log in before you can comment on or make changes to this bug.