Bug 152167 - libgnome fails to build on alpha
Summary: libgnome fails to build on alpha
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnome   
(Show other bugs)
Version: rawhide
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-25 15:27 UTC by Sergey Tikhonov
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 20:54:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (512 bytes, patch)
2005-03-25 15:27 UTC, Sergey Tikhonov
no flags Details | Diff

Description Sergey Tikhonov 2005-03-25 15:27:32 UTC
Description of problem:
libgnome fails to build on linux/alpha
The problem is that function parameter is defined as va_list and caller
tries to pass 0 as a parameter. va_list on alpha is not a pointer.

Version-Release number of selected component (if applicable):
libgnome-2.9.1-3

Additional info:
In attached patch I used dummy va_list variable and passed it, because the
called function checks number of passed parameters first.

Comment 1 Sergey Tikhonov 2005-03-25 15:27:33 UTC
Created attachment 112348 [details]
Proposed patch

Comment 2 Matthias Clasen 2005-04-21 20:54:46 UTC
Please report this problem upstream. We're not going to patch our rpms for
architectures which we don't even support.


Note You need to log in before you can comment on or make changes to this bug.