Bug 152168 - evolution assumes (wrong) mailbox name
evolution assumes (wrong) mailbox name
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-03-25 10:35 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 08:48:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 273627 None None None Never

  None (edit)
Description Need Real Name 2005-03-25 10:35:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Epiphany/1.4.4

Description of problem:
Evolution 2.2 assumes that the mailbox name and the username are the same.
This isn't always true, and this assumption was not made in 2.0.

Accessing Exchange with 2.2 is no longer possible for me.

When evolution connect to the Exchange server, it sends a
 GET /exchange/username/ HTTP/1.1
and authenticates using username.

Previously, it would send a
 GET /exchange/mailbox_name/ HTTP/1.1
and authenticates using username.

Evolution now assumes the two are the same.

Marking as above Normal since this is a major loss of functionality, i.e. evolution-connector doesn't work.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-03-29 02:45:59 EST
Reported to bugzilla.ximian.com:
 http://bugzilla.ximian.com/show_bug.cgi?id=74168
Comment 2 Ronny Buchmann 2005-04-12 13:30:51 EDT
Dave, please update to 2.2.2, it is supposed to be fixed there.
Comment 3 Ronny Buchmann 2005-04-12 13:36:13 EDT
um, probably not fixed, but an upgrade wouldn't hurt I think
Comment 4 Dave Malcolm 2005-05-16 17:33:54 EDT
Ronny: FWIW, evolution-connector-2.2.2 made it into FC4 Test3 and is available
in Rawhide as well

Does it fix the problem for you?
Comment 5 Dave Malcolm 2005-05-16 18:12:53 EDT
Has anyone got this to work with the latest packages?
(reopening the bug)
Comment 6 Ronny Buchmann 2005-05-17 06:11:43 EDT
With ximian-connector-setup-2.2 I can setup the account and succesfully connect
in evolution.

The account setup in evolution still doesn't work.

see my comment in upstream bugzilla
Comment 7 Need Real Name 2005-05-17 06:45:43 EDT
I can also confirm that account setup from evolution fails.
But ximian-connector-setup-2.2 works.
Comment 9 Need Real Name 2006-11-17 08:48:48 EST
Closing. FC4 bug.

Note You need to log in before you can comment on or make changes to this bug.