Bug 152173 - rpm once again doesn't work with non-NPTL kernels
rpm once again doesn't work with non-NPTL kernels
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-25 11:36 EST by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 21:12:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2005-03-25 11:36:21 EST
For a long time, rpm was being compiled in such a way that it would work on 
non-NPTL kernels.  As of rpm-4-4.1-2, it no longer does.  Note that this is 
independent of the other bug which was closed WONTFIX about problems caused by 
db4 being compiled with NPTL support -- despite the fact that db4 was compiled 
with NPTL support, until recently rpm worked on non-NPTL machines, but it no 
longer does.  Was this a conscious decision or an inadvertent change?  If the 
latter, can it be fixed?
Comment 1 Jeff Johnson 2005-03-25 11:49:36 EST
"Work" with non-nptl kernels was not perfect. Reverting to DB_PRIVATE
if/when shared posix mutexes are not functional was not the right thing
to do and led to __db* cache corruption.

No fix to the problem of rpm compiled expecting +NPTL but running
in -NPTL environment is known, as db4 locks are compiled in. You
cannot have it both ways.
Comment 2 Jeremy Katz 2005-04-27 21:12:33 EDT
With FC4, getting things working without a 2.6 kernel is virtually impossible. 
Which means that you always have nptl.

Note You need to log in before you can comment on or make changes to this bug.