Bug 152191 - USB profile 093a:010e device
USB profile 093a:010e device
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hwdata (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-25 16:15 EST by R P Herrold
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: rawhide
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-29 11:40:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2005-03-25 16:15:08 EST
This is the USB header information, with detail on the '0x010e' Product ID

It is a 'Gemini' Keychain Digital Camera -- the latest Fedora Gphoto2 picks it up.

Bus 001 Device 002: ID 093a:010e Pixart Imaging, Inc.
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass       255 Vendor Specific Subclass
  bDeviceProtocol       255 Vendor Specific Protocol
  bMaxPacketSize0         8
  idVendor           0x093a Pixart Imaging, Inc.
  idProduct          0x010e
  bcdDevice            1.00
  iManufacturer           0
  iProduct                2 Dual-Mode Digital Camera
  iSerial                 0
  bNumConfigurations      1
Comment 1 Thomas Woerner 2005-11-17 07:53:51 EST
What is the problem with this device?
Comment 2 R P Herrold 2006-07-14 22:46:08 EDT
the problem is that application space gphoto2 knows the USB ID [assumedly from a
local profile database], but system level usbutils does not because the profile
is not is its database, and needs to be added to usbutils.
Comment 3 R P Herrold 2006-07-14 22:46:19 EDT
the problem is that application space gphoto2 knows the USB ID [assumedly from a
local profile database], but system level usbutils does not because the profile
is not is its database, and needs to be added to usbutils.
Comment 4 Thomas Woerner 2006-07-15 09:03:47 EDT
What does 'lsusb -v' report on this device?
Comment 5 R P Herrold 2006-07-17 11:35:18 EDT
The 'lsusb -v' output is in comment # 1 already -- as noted "This is the USB
header information, with detail on the '0x010e' Product ID".

...
  idProduct          0x010e
...

What are you asking beyond that information?
Comment 6 R P Herrold 2007-01-08 18:09:24 EST
ping -- still not answered -- requested info in the ticket -- what else do you
need from me?
Comment 7 R P Herrold 2007-01-08 18:10:52 EST
the issue is the gphoto2 knows it but usbutils, against which it is filed, does
not have the profile, and needs it added
Comment 8 Thomas Woerner 2007-01-09 07:12:48 EST
usbutils is using the database of hwdata.

Assigning to hwdata.
Comment 9 Karsten Hopp 2007-01-09 08:21:45 EST
This needs to be added at the upstream repository at
http://www.qbik.ch/usb/devices/ 
That's where we get our usb data from and each new entry needs to be submitted
and reviewed there. Please create an account there, log in and click at 'Manage
my devices' on the left side to add new entries.

Change this bugzilla's status back to 'ASSIGNED' when you're done and I'll get the
new usb.ids file
Comment 10 R P Herrold 2007-01-09 10:29:27 EST
added to 'My Devices'
Comment 11 Karsten Hopp 2007-01-25 07:07:38 EST
I hope it'll get picked up automatically when a new usb list is being created.
At least it looks like upstream doesn't release new usb.ids files that often,
the last one ist still from 2006/12/12. That's what currently is in FC-7 hwdata.
Comment 12 R P Herrold 2007-02-25 18:26:02 EST
"I hope" ???

I guess what you are saying is that the process of using an upstream archive to
capture fixes is broken.

There is not one iota more information now, than there was when I opened this
bug: 2005-03-25 No-one upstream is interested.  Shall it be fixed in Fedora, or
does it make no sense to file bugs here?
Comment 13 Bill Nottingham 2007-03-02 12:29:21 EST
Moving to 'devel' as discussed on
https://www.redhat.com/archives/fedora-devel-list/2007-March/msg00095.html.
Comment 14 R P Herrold 2007-03-29 11:40:24 EDT
it has appeared -- thanks

I still think the sigs acquisition process is messed up in that it took two
years, but whatever ...                                     

Note You need to log in before you can comment on or make changes to this bug.