Bug 152213 - Installation on a USB drive does not boot
Summary: Installation on a USB drive does not boot
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-26 15:15 UTC by Dmitri Varsanofiev
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 19:05:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dmitri Varsanofiev 2005-03-26 15:15:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
After installing on a USB drive (in expert mode), RHEL does not boot. The problem is caused by the lack of the USB drivers in the initial ramdisk image (inird). 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install RHEL in expert mode to a USB drive
2. Boot
3. Panic 
  

Actual Results:  Panic, since root was not mounted

Expected Results:  Normal boot

Additional info:

The problem is well known, solution is to add the USB drivers to the inital ramdisk image: http://www.simonf.com/usb/ . Workaround is very time-consuming.

Comment 1 Jeremy Katz 2005-03-28 19:05:52 UTC
Installs to USB disks are not supported, this is why they're not allowed by default.


Note You need to log in before you can comment on or make changes to this bug.