Bug 152250 - GCC fails to compile mplayer cvs
Summary: GCC fails to compile mplayer cvs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc34   
(Show other bugs)
Version: 3
Hardware: athlon Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-26 19:37 UTC by Warren Sturm
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-27 18:45:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested preprocessed source (265.81 KB, text/plain)
2005-03-26 19:37 UTC, Warren Sturm
no flags Details

Description Warren Sturm 2005-03-26 19:37:30 UTC
Description of problem:
Compile of mplayer dies on AMD XP 2700+

Version-Release number of selected component (if applicable):
gcc 3.4.2

How reproducible:
always

Steps to Reproduce:
1. cd /compile; mkdir mplayer; cd mplayer; cvs -d
:pserver:anonymous@mplayerhq.hu:/cvsroot/mplayer co main
2. updated ffmpeg from cvs ; cd /compile; cvs -d
:pserver:anonymous@mplayerhq.hu:/cvsroot/ffmpeg co ffmpeg
3. copied required ffmpeg directories to mplayer tree
(cd /compile/ffmpeg; tar -cf - libavcodec libavformat) | (cd
/compile/mplayer/main; rm -rf libavcodec libavformat; tar -xvf -)
4. cd /compile/mplayer/main;  ./configure \
	--enable-xmms \
	--enable-largefiles \
	--enable-menu \
	--enable-debug=3
5. make 
Actual results:

cc -c -I../libvo -I../../libvo -I/usr/X11R6/include -fno-PIC -W -Wall
-Wno-unused-parameter -O2 -march=athlon-4 -mtune=athlon-4 -g3  -D_REENTRANT
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -I. -Inative -I.. -I../libmpdemux
-I../loader   -D_GNU_SOURCE -o vf_spp.o vf_spp.c
*** glibc detected *** malloc(): memory corruption: 0x09e42e10 ***
vf_spp.c: In function `softthresh_mmx':
vf_spp.c:282: internal compiler error: Aborted
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
*** glibc detected *** malloc(): memory corruption: 0x09f0fcb0 ***
*** glibc detected *** malloc(): memory corruption: 0x0950dcb0 ***
Preprocessed source stored into /tmp/ccWQzfs0.out file, please attach this to
your bugreport.
make[1]: *** [vf_spp.o] Error 1
make[1]: Leaving directory `/data/opt/compile/mplayer/main/libmpcodecs'
make: *** [libmpcodecs/libmpcodecs.a] Error 2

Expected results:
Compilation should complete with the mplayer and mencoder programs generated.

Additional info:
gcc-3.4.2-6.fc3
glibc-2.3.4-2.fc3

Comment 1 Warren Sturm 2005-03-26 19:37:31 UTC
Created attachment 112361 [details]
requested preprocessed source

Comment 2 Jakub Jelinek 2005-03-27 18:45:03 UTC
Can't reproduce this with gcc-3.4.3-22.fc3 (current FC3 testing update).

Comment 3 Warren Sturm 2005-03-27 19:47:26 UTC
Thanks.  That seems to hae been the fix.  Updated the requisite 16 packages.



Note You need to log in before you can comment on or make changes to this bug.