Bug 152260 - FC4T1 "Everything Install" + yum update
FC4T1 "Everything Install" + yum update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: python-docs (Show other bugs)
4
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Mihai Ibanescu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-26 17:43 EST by Jason Powers
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-07 18:02:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Powers 2005-03-26 17:43:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
I'm not much of a python coder, so I figured I'd help with the debugging of the install. As a test I ran an "Everything Install" of FC4T1 x86_64 and then yum -y update, which fails with dependency errors, some of which are already documented:

152019 gstreamer-plugins
151932 jpilot
152186 gnome-python-libwnck

I'd be very surprised if I was the first person who tried the "Everything" install, but as I can't find two of the errors in your database at present, I thought I'd add them here:

python-docs does not update with the rest of python from 2.4-4 to 2.4-6
openoffice.org-langpack-* will not upgrade to 1.9.87-2

The three already documented plus the two I noted above are the only thing holding back yum right now, which is pretty impressive considering the number of packages involved.

As a temporary workaround, I run:

yum -y remove python-docs openoffice.org-langpack-* gstreamer-plugins jpilot gnome-python-libwnc

and then 

yum -y update 

which installs, as of today, 789 packages. 

It weirdly gives the following message before doing so:

Performing the following to resolve dependencies:
  Install: jsch.noarch 0:0.1.17-2jpp_1fc - development
  Install: jzlib.noarch 0:1.0.5-2jpp_1fc - development
  Install: libdbi-drivers.x86_64 0:0.7.1-2 - development
  Install: sqlite-devel.x86_64 0:3.1.2-1 - development

I'm not sure what this indicates, are these not in the "Everything" install, or are they not where they belong in the repodata somewhere? If I install "Everything" and then (I guess) update "Everything", why is it hitting dependencies, since those packages presumably need to be updated themselves by the prior step anyway? 

So I've tested this about 5 times in the last week and this is consistent. Also, at work I'm really lazy and have unlimited bandwidth, so we are actually talking about a real-world scenario here: I normally do i386 installs of Fedora on about 20 servers, and I'm thinking about upgrading some to 64 bit. I get similar, but slightly different messages from the i386 install, and I will post that seperately.

Version-Release number of selected component (if applicable):
python 2.4-4

How reproducible:
Always

Steps to Reproduce:
1. Install "Everything" from FC4T1
2. import 50000000000 keys from all over creation
3. realize you need to shut GPG keys off for the dev tree
4. do so
5. run yum -y update
6. make a list of dependency errors
7. post list to bugzilla

Actual Results:  After the initial pass of yum -y update, the process errors out with dependency issues, listed above.

After I remove the packages in question, I can run yum -y update and it works, then I install the packages and they work.

Expected Results:  Should not have to exclude a few packages from the update process.

Additional info:

I can't decide whether this is a low or normal bug. The workaround is easy enough, but I do this all day every day, I've seen on the mailing list that other people don't think to yum remove or rpm -e things that get in their way.

I guess it would be normal if you expect the development tree to become FC4 eventually.
Comment 1 Sean Bruno 2005-03-27 18:52:59 EST
I was just about to submit a ticket for the i386 depend errors as I did an
"Everything install" on my machine.

I have the same depend errors listed in this ticket with the addition of
openoffice.org-core which I have submitted seperately:

Comment 2 Sean Bruno 2005-03-31 22:32:39 EST
This is still an issue for me.  I cannot update "tkinter" as well due to this error.
Comment 3 Sean Bruno 2005-04-01 16:52:34 EST
I removed python-docs and updated tkinter along with the rest of python.  After
this update was complete, I installed the new python-docs rpm from rawhide.  I
think that this issue can be closed at this point as I am completely up2date.
Comment 4 Mihai Ibanescu 2005-04-07 18:02:14 EDT
Closing.

Note You need to log in before you can comment on or make changes to this bug.