This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 152268 - Rebuilding of kernel fails, if %_enable_debug_packages isn't set
Rebuilding of kernel fails, if %_enable_debug_packages isn't set
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-26 20:04 EST by Robert Scheck
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.11-1.1219_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 10:35:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2005-03-26 20:04:51 EST
Description of problem:
Rebuilding of kernel fails, if %_enable_debug_packages of rpm isn't set, 
because vmlinux isn't packaged to a -debuginfo rpm package.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1202_FC4

How reproducible:
Everytime: Comment out %_enable_debug_packages in /usr/lib/rpm/redhat/macros 
and try rebuilding of the kernel package.

Actual results:
--- kernel-2.6.spec       2005-03-27 03:00:08.000000000 +0200
+++ kernel-2.6.spec.rsc   2005-03-27 01:59:50.000000000 +0100
@@ -791,7 +791,9 @@

     # Start installing the results

+    %if "%{_enable_debug_packages}" == "1"
     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
+    %endif
     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
@@ -842,8 +844,10 @@
     #
     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
     #
+    %if "%{_enable_debug_packages}" == "1"
     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
+    %endif

     # gpg sign the modules
 %if %{signmodules}

Expected results:
Apply of the suggested patch or better (the idea is taken from glibc.spec).
Comment 1 Warren Togami 2005-03-27 16:29:31 EST
What is the benefit of disabling the debug package?
Comment 2 Robert Scheck 2005-03-28 16:15:42 EST
In the case of Red Hat or the Fedora Team: None.
In the case of other people, which don't want to have or don't need the debuginfo
package, the suggested change makes sense. Let me say, it's only a small 
advantage for rebuilding the kernel package in another (possible and not so far 
away) way. On the other hand you could ask the same to glibc ;-)

Last but not least, I think, the 4 additional lines should hurt nobody in any
case, don't it?
Comment 3 Dave Jones 2005-03-28 16:27:29 EST
fixed for next build.
Comment 4 Robert Scheck 2005-03-31 10:35:59 EST
Commited for 2.6.11-1.1210_FC4 and built with 2.6.11-1.1219_FC4 in Rawhide. 
Thank you, closing.

Note You need to log in before you can comment on or make changes to this bug.