Bug 152274 - kudzu "Keep existing configuration" option does not persist
kudzu "Keep existing configuration" option does not persist
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-26 23:21 EST by Jonathan Berry
Modified: 2014-03-16 22:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 15:08:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jonathan Berry 2005-03-26 23:21:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

Description of problem:
I have FC3 installed on my laptop.  Being a laptop, it has devices plugged up at times that must be disconnected when moving the laptop, such as my USB printer.  When kudzu detects that such devices are not there, it brings up a prompt asking me what to do about it.  I always select the choice to "Keep existing configuration."  From the description, I interpret this choice to mean, "remember about the device, but don't prompt me about it again if you don't see it."  However, I get prompted about it the next time the device is missing.  This probably occurs after the device has been hooked up to the machine again, I have not tested unhooking the device, selecting to keep the config, and rebooting without hooking the device up again.

Version-Release number of selected component (if applicable):
kudzu-1.1.95-1

How reproducible:
Always

Steps to Reproduce:
1. Configure a removable device, say  USB printer with kudzu
2. Shutdown the machine and unplug the device
3. Boot up, kudzu asks about the device, tell it to "Keep existing configuration"
4. Plug device back up and reboot with device plugged in
5. Unplug device and reboot without it plugged in again
6. See kudzu prompt again
  

Actual Results:  kudzu still prompts me about the missing device.

Expected Results:  Perhaps I misinterpret the description, but I think that kudzu should remember my choice to "Keep existing configuration"  If this is not the intended function, I request that it be made to work this way, or another option be added that will allow me to tell kudzu not to bother me again if the device is missing, even if it is not missing at some point, so I will *never* be prompted again about it.

Additional info:

I've marked this as an RFE because I'm not sure my interpretation is the actual meaning of the description.  It has been suggested that perhaps if the device is found again, then this choice is nullified.  I have not tested if having the device removed for consecutive reboots results in a prompt or not (I can do that if wanted).  If this behavior is not what is intended, and kudzu should indeed not bother me about the device, then please consider this a bug.
This prompt is rather annoying and increases the boot time by 30 sec unless you interact with it.  For a laptop, occasional removal of peripheral devices is common, and kudzu should not be concerned with it.
Comment 1 Bill Nottingham 2005-03-28 15:08:41 EST
This prompting is removed in the current devel version, so I'm not sure that the
underlying issue will be addressed. Closing.

Note You need to log in before you can comment on or make changes to this bug.