Bug 152280 - totem-video-thumbnailer crashes on use
totem-video-thumbnailer crashes on use
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-27 05:22 EST by Need Real Name
Modified: 2013-03-13 00:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 16:06:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-27 05:22:38 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050322 Epiphany/1.5.8

Description of problem:
I'm trying to create a thumbnail for an mjpeg file, the same as nautilus does.

$ totem-video-thumbnailer ./imgp1234.avi out.png

(totem-video-thumbnailer:3575): GLib-GObject-WARNING **: gsignal.c:1716: signal `group-switch' is invalid for instance `0x838e108'

(totem-video-thumbnailer:3575): GLib-GObject-WARNING **: IA__g_object_set_valist: object class `GstPlayBin' has no property named `suburi'

(totem-video-thumbnailer:3575): GStreamer-CRITICAL **: gst_element_make_from_uri: assertion `gst_uri_is_valid (uri)' failed
totem-video-thumbnailer couln't open file './imgp1234.avi'
Reason: No URI handler implemented for "./imgp1234.avi".


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-03-27 06:22:07 EST
It's not a crash - it just doesn't work.

The workaround is to use 
totem-video-thumbnailer file://$PWD/imgp1234.avi $PWD/out.png

euck :/
Comment 2 John (J5) Palmieri 2005-03-29 16:06:00 EST
it uses gnome-vfs URI's.  What you see is an assert, not a crash, saying the URI
provided is not in a format that gstreamer can understand.  This is not realy a
bug but should be filed upstream if you would like to see it fixed.
Comment 3 Need Real Name 2005-03-29 16:23:16 EST
Fair enough, have done:
 http://bugzilla.gnome.org/show_bug.cgi?id=172030

I do think this *is* a bug though, because a command-line tool should be usable
as if it were any other command-line tool - without any special syntax. If the
thumbnailer were a library function, then fair enough, but it isn't.
Comment 4 Need Real Name 2005-03-30 07:18:48 EST
Fixed upstream.

Note You need to log in before you can comment on or make changes to this bug.