Bug 1522917 - Review Request: perl-Algorithm-Loops - Perl module for looping constructs
Summary: Review Request: perl-Algorithm-Loops - Perl module for looping constructs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1520569
TreeView+ depends on / blocked
 
Reported: 2017-12-06 17:51 UTC by Robert-André Mauchin 🐧
Modified: 2018-02-27 20:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-27 20:39:11 UTC
Type: ---
jplesnik: fedora-review+


Attachments (Terms of Use)

Description Robert-André Mauchin 🐧 2017-12-06 17:51:42 UTC
Spec URL: https://raw.githubusercontent.com/eclipseo/packaging/044a039/perl-Algorithm-Loops.spec
SRPM URL: https://copr-be.cloud.fedoraproject.org/results/eclipseo/ravada/fedora-rawhide-x86_64/00685135-perl-Algorithm-Loops/perl-Algorithm-Loops-1.032-1.fc28.src.rpm

Description:
Looping constructs: NestedLoops, MapCar*, Filter, and NextPermute*

Fedora Account System Username: eclipseo

Comment 3 Jitka Plesnikova 2017-12-13 12:20:07 UTC
Source file is ok
Summary is ok
License is ok

Description 
TODO: Please update the description to provide a bit more information. 
      E.g. to something like this:
  Algorithm::Loops provides several functions (NestedLoops, MapCar*, Filter,
  and NextPermute*) for doing different types of looping constructs. By
  default, no functions are exported into a namespace.

URL and Source0 are ok
All tests passed

BuildRequires are ok
FIX: Please add the version restriction for perl(ExtUtils::MakeMaker) to
     6.76 or higher, because NO_PACKLIST option was added in this version.

$ rpm -qp --requires perl-Algorithm-Loops-1.032-1.fc28.noarch.rpm | sort | uniq -c
      1 perl(Carp)
      2 perl(Exporter)
      1 perl(:MODULE_COMPAT_5.26.1)
      2 perl(strict)
      2 perl(vars)
      1 perl(warnings)
      1 rpmlib(CompressedFileNames) <= 3.0.4-1
      1 rpmlib(FileDigests) <= 4.6.0-1
      1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
      1 rpmlib(PayloadIsXz) <= 5.2-1
Binary requires are almost Ok.
FIX: Please remove explicit run-requires of 'perl(Exporter)',
     'perl(strict)' and 'perl(vars)', because they are found by
     generators.

$ rpm -qp --provides perl-Algorithm-Loops-1.032-1.fc28.noarch.rpm | sort | uniq -c
      1 perl(Algorithm::Loops) = 1.032
      1 perl-Algorithm-Loops = 1.032-1.fc28
Binary provides are Ok.

$ rpmlint ./perl-Algorithm-Loops*
2 packages and 1 specfiles checked; 0 errors, 0 warnings.
Rpmlint is ok

TODO: Replace variable PERL_INSTALL_ROOT obsoleted with DESTDIR name in %install.
TODO: Please add 'ex' to %doc.

Please correct all 'FIX' issues and consider fixing 'TODO' items and
provide new spec file.

The package is not approved.

Comment 5 Jitka Plesnikova 2017-12-14 10:51:20 UTC
> Description 
> TODO: Please update the description to provide a bit more information. 
>       E.g. to something like this:
>   Algorithm::Loops provides several functions (NestedLoops, MapCar*, Filter,
>   and NextPermute*) for doing different types of looping constructs. By
>   default, no functions are exported into a namespace.
Ok.

> BuildRequires are ok
> FIX: Please add the version restriction for perl(ExtUtils::MakeMaker) to
>      6.76 or higher, because NO_PACKLIST option was added in this version.
Ok.
 
> $ rpm -qp --requires perl-Algorithm-Loops-1.032-1.fc28.noarch.rpm | sort |
> uniq -c
>       1 perl(Carp)
>       2 perl(Exporter)
>       1 perl(:MODULE_COMPAT_5.26.1)
>       2 perl(strict)
>       2 perl(vars)
>       1 perl(warnings)
>       1 rpmlib(CompressedFileNames) <= 3.0.4-1
>       1 rpmlib(FileDigests) <= 4.6.0-1
>       1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
>       1 rpmlib(PayloadIsXz) <= 5.2-1
> Binary requires are almost Ok.
> FIX: Please remove explicit run-requires of 'perl(Exporter)',
>      'perl(strict)' and 'perl(vars)', because they are found by
>      generators.
Ok.
 

> TODO: Replace variable PERL_INSTALL_ROOT obsoleted with DESTDIR name in
> %install.
Ok.

> TODO: Please add 'ex' to %doc.
Not change.

The package is approved.

Comment 6 Gwyn Ciesla 2017-12-14 13:50:26 UTC
(fedrepo-req-admin):  The Pagure repository was created at https://src.fedoraproject.org/rpms/perl-Algorithm-Loops. You may commit to the branch "f27" in about 10 minutes.

Comment 7 Fedora Update System 2017-12-14 15:55:33 UTC
perl-Algorithm-Loops-1.032-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a9b144da91

Comment 8 Fedora Update System 2017-12-14 16:03:12 UTC
perl-Algorithm-Loops-1.032-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5d200ddd4

Comment 9 Fedora Update System 2017-12-15 11:28:58 UTC
perl-Algorithm-Loops-1.032-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a9b144da91

Comment 10 Fedora Update System 2017-12-15 12:18:53 UTC
perl-Algorithm-Loops-1.032-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5d200ddd4

Comment 11 Fedora Update System 2017-12-26 16:30:35 UTC
perl-Algorithm-Loops-1.032-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-12-28 02:49:36 UTC
perl-Algorithm-Loops-1.032-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2018-02-07 20:36:45 UTC
perl-Algorithm-Loops-1.032-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-d314769f44

Comment 14 Fedora Update System 2018-02-08 08:41:52 UTC
perl-Algorithm-Loops-1.032-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-d314769f44

Comment 15 Fedora Update System 2018-02-27 20:39:11 UTC
perl-Algorithm-Loops-1.032-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.