Bug 152292 - 2.4 headers 2.6 kernel
2.4 headers 2.6 kernel
Status: CLOSED DUPLICATE of bug 154493
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-27 13:09 EST by Graham Leggett
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-17 17:46:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2005-03-27 13:09:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050130 Fedora/1.7.5-3

Description of problem:
A default installation of FC3 sees headers from a v2.4 kernel installed, when a 2.6 kernel is present by default.

To fix this, the glibc-kernheaders package should be scrapped entirely and replaced with a kernel-devel package that implements the kernel-headers requirement.

At this point it is not possible to compile any kernel v2.6 software under FC3, even though FC3 is kernel v2.6 based.


Version-Release number of selected component (if applicable):
2.4-9.1.87

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:
Comment 1 Graham Leggett 2005-04-16 18:00:09 EDT
Um... "closed - notabug" without a comment explaining why?

Where are the 2.6 headers on the Fedora 3 system?
Comment 2 David Woodhouse 2005-04-17 09:41:08 EDT
Well, there wasn't any comment explaining why you think it _is_ a problem
either. If there are problems which prevent compilation of non-buggy software,
be specific about the problem.
Comment 3 Graham Leggett 2005-04-17 16:41:13 EDT
"At this point it is not possible to compile any kernel v2.6 software under FC3,
even though FC3 is kernel v2.6 based.".

DVB device drivers refuse to compile and install, as they are kernel v2.6 only.
This means DVB cannot be used with Fedora 3.
Comment 4 David Woodhouse 2005-04-17 17:46:32 EDT
Someone filed a proper bug report about DVB and actually said what their problem
was, so it already got fixed. 

*** This bug has been marked as a duplicate of 154493 ***
Comment 5 Graham Leggett 2005-04-17 18:06:57 EDT
How can you tell me my specific DVB bug is fixed, when I haven't told you what
the DVB bug was yet?

How to debug software 101: Separate the problem into its individual components,
and address them separately and specifically.

FC3 distributing v2.4 headers with the v2.6 kernel is a self contained bug and
it's not fixed yet, nor has any technical reason been given for why v2.4 headers
should appear on a v2.6 system.

Are you trying to reach a quota or something, or is Microsoft-style Bug
Denial(tm) now the official policy of Red Hat?
Comment 6 David Woodhouse 2005-04-17 18:58:45 EDT
The DVB headers in the current glibc-kernheaders package are up to date with the
current 2.6 kernel. Since you have filed a bug report without actually telling
what the bug report is, it is indeed somewhat difficult for me to respond -- but
I'm _guessing_ that it's fixed in the latest package, because someone actually
filed a _coherent_ bug report about DVB and it got fixed.

Note You need to log in before you can comment on or make changes to this bug.