Bug 152298 - pcmcia not powered on and timeouts from tg3 driver
Summary: pcmcia not powered on and timeouts from tg3 driver
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-27 21:18 UTC by Roy-Magne Mo
Modified: 2015-01-04 22:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 00:57:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from dmesg / boot (16.09 KB, text/plain)
2005-03-27 21:20 UTC, Roy-Magne Mo
no flags Details

Description Roy-Magne Mo 2005-03-27 21:18:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2 Fedora/1.0.2-2

Description of problem:
After upgrading from kernel-2.6.11-1.1185_FC4 through kernel-2.6.11-1.1191_FC4, kernel-2.6.11-1.1202_FC4 and kernel-2.6.11-1.1208_FC4 the pcmcia-reader won't power on and the tg3 driver times out when trying to send traffic. 

2.6.11-1.1185_FC4 works as expected

Tried booting with pci=routeirq, it made no difference.

After a while the tg3 oopses

output of dmesg and oops attached




Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1208_FC4

How reproducible:
Always

Steps to Reproduce:
1. boot with a kernel after 2.6.11-1.1185_FC4
2.
3.
  

Actual Results:  no net due to no network cards being able to initialize

Additional info:

Hardware: Dell Latitude D600 prism54g as pcmcia card.

Comment 1 Roy-Magne Mo 2005-03-27 21:20:56 UTC
Created attachment 112378 [details]
output from dmesg / boot

Comment 2 Roy-Magne Mo 2005-04-10 00:09:37 UTC
pcmcia and tg3 works with kernel-2.6.11-1.1233_FC4 - did not work with previous
kernels. 

Comment 3 Roy-Magne Mo 2005-04-14 20:14:12 UTC
(In reply to comment #2)
> pcmcia and tg3 works with kernel-2.6.11-1.1233_FC4 - did not work with previous
> kernels. 


Just seemed like a fluke, does seem to happen still

Comment 4 Roy-Magne Mo 2005-04-24 15:27:34 UTC
Could this be the same problem? http://bugme.osdl.org/show_bug.cgi?id=4501

Comment 5 Roy-Magne Mo 2005-05-03 17:53:49 UTC
I does seem like kernel-2.6.11-1.1282_FC4 could have fixed my problem, booted
twice now with both tg3 and pcmcia


Note You need to log in before you can comment on or make changes to this bug.