Bug 152308 - Hal dies/sleeps randomly
Hal dies/sleeps randomly
Status: CLOSED DUPLICATE of bug 136255
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-28 00:06 EST by Steve Bangert
Modified: 2013-03-05 22:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 13:40:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Bangert 2005-03-28 00:06:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
hal dies/sleeps at random, can stay functional for 10 minutes or up to 2 hours, can't assocciate failure with any event.

Version-Release number of selected component (if applicable):
hal-0.4.7-1.FC3

How reproducible:
Always

Steps to Reproduce:
1. boot up machine
2. hal works ok for 10 min to two hours
3. then dies for no apparent reson
  

Actual Results:  hal dies/sleeps

Expected Results:  hal should remain functional, log file attached but I don't feel its useful.

Additional info:

00:33:58.382 [I] linux/osspec.c:1557: ==========================================
00:33:58.382 [I] linux/osspec.c:1558: ==== hotplug_counter is now 0
00:33:58.382 [I] linux/osspec.c:1559: ==========================================
00:33:58.382 [I] callout.c:193: Callouts done for /org/freedesktop/Hal/devices/usb_device_4fc_53 31_100_-1_noserial
#############  at this point Hal stop's responding   ################
Comment 1 David Zeuthen 2005-03-28 10:53:10 EST
When this happens, what is the output of 'ps aux |grep hald'?

Thanks,
David
Comment 2 Steve Bangert 2005-03-28 12:22:01 EST
[skb@localhost ~]$ ps aux | grep hald
root      5017  1.5  1.2  9352 6480 ?        Ss   08:52   0:00 hald
skb       6050  0.0  0.1  4936  660 pts/1    R+   08:53   0:00 grep hald

[skb@localhost ~]$ ps aux | grep hald
root      5017  0.0  1.3  9716 6876 ?        Ds   08:52   0:00 hald
skb       6771  0.0  0.1  4740  652 pts/1    R+   09:09   0:00 grep hald

Top output, Hal is working, second output, Hal has died.
Comment 3 David Zeuthen 2005-03-28 13:40:21 EST
Known bug with the kernel - this is a duplicate of bug 136255.

FYI hal 0.5.x from Rawhide should be able to work around this.


*** This bug has been marked as a duplicate of 136255 ***
Comment 4 Steve Bangert 2005-03-29 01:40:18 EST
David, as far as using hal-0.5.0 it's NOT compatable with fc3, at least not
without major changes, like updating dbus, udev, initscripts and more. As far as
bug 136255 I don't think it's the same bug, I don't have to use any usb storage
devices to get hal to die, please reconsider.
Comment 5 David Zeuthen 2005-03-29 12:33:46 EST
The defect with the kernel, putting hald into state D, isn't exclusive to USB
mass storage devices. There is nothing to reconsider, sorry; it's a defect with
the kernel and to work around it requires massive changes to hal. These changes
are in hal 0.5.x, but they are not going to be backported to FC3, sorry.

Note You need to log in before you can comment on or make changes to this bug.