Bug 152330 - RFE: add /dev/nvram to console.perms
RFE: add /dev/nvram to console.perms
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: pam (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-28 12:08 EST by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 07:48:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2005-03-28 12:08:21 EST
Granting logged on users read access to /dev/nvram would be nice; for example
tpb from Fedora Extras could use that.  More details about the tpb case:
https://www.redhat.com/archives/fedora-packaging/2005-March/msg00077.html

How about adding for example this to console.perms?

  <console> 0400 /dev/nvram 0600 root
Comment 1 Tomas Mraz 2005-04-26 07:48:54 EDT
This is not right because the user can then chmod the /dev/nvram to any value
and overwrite the CMOS contents. The only solution would be to consider if
reading the contents of /dev/nvram is really harmless and if that's true then
assign it 0644 permissions in the udev permissions file.
Comment 2 Ville Skyttä 2005-04-26 10:13:42 EDT
Good point, thanks.  The chmod problem never occurred to me, will look for
another solution.

Note You need to log in before you can comment on or make changes to this bug.