Bug 152350 - pl2303 HX drops first character after open
pl2303 HX drops first character after open
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-03-28 14:07 EST by bperkins
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 01:18:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description bperkins 2005-03-28 14:07:38 EST
Description of problem:
pl2303 "type 2" device drops characters on read sometimes. This is the HX
version of the chip.  The "type 1" device works OK.  This is on a thinkpad R32
with  an INTEL 82801CA/CAM USB controller.  My Other USB devices all work fine.

Version-Release number of selected component (if applicable):
 2.6.10-1.12_FC2, but I've seen similar behavior in recent kernels.  There was a
fairly recent patch to pl2303 that doesn't seem to help.

How reproducible:
Always (as long as you try twice)

Steps to Reproduce:
I've created a test script that reproduces the problem.  There's a little bit of
cruft in it to produce the debug log.  It also tests the older version of the
adapter, which works OK.  I've included both so you can see the difference.


It requires this little C helper program.
This program is designed to work with my sportrak GPS, but it behaves the same
if you short pins 2 and three together ( I used a little jumper)

Actual results:
The first time the test program is run it works. 
The second time it drops the first character.

Additional info:

Here are the results of the test with debug=1 turned on.
http://throb.netspace.org/~bperk/pl2303-type1b.log (old working adapter)
http://throb.netspace.org/~bperk/pl2303-type2b.log (HX version, non working)

The problem show up on line 152 or so of pl2303-type2b.log
Where it says
Mar 22 12:35:17 thump kernel: PL-2303 ttyUSB0: pl2303_read_bulk_callback -
length = 1, data = 50

Which should  have been preceded by a '$' (0x24)

I've talked to the driver maintainer greg@kroah.com, who has pretty much given up.  

I tried contacting prolific, and they won't respond.
I also tried playing the driver, and didn't get very far.

I did find that commenting out _all_ of the FISH SOUP macros had no effect, i.e.
the driver works, but is still broken as I've described.  

I tried to compare what the driver is trying to do compared with usbsnoop under
windows.  I didn't get very far with this either. 

I spent a lot of time on this, so I thought I'd report it.
Comment 1 Dave Jones 2005-04-16 01:18:47 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.