Bug 1523692 - Manual creation of thinpools fail when no size specified.
Summary: Manual creation of thinpools fail when no size specified.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat Storage
Component: gdeploy
Version: rhgs-3.3
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: RHGS 3.3.1 Async
Assignee: Devyani Kota
QA Contact: Manisha Saini
URL:
Whiteboard:
Depends On:
Blocks: 1581561
TreeView+ depends on / blocked
 
Reported: 2017-12-08 15:53 UTC by Cal Calhoun
Modified: 2021-03-11 16:34 UTC (History)
14 users (show)

Fixed In Version: gdeploy-2.0.2-21
Doc Type: If docs needed, set a value
Doc Text:
Earlier, if no size was specified, 100% of the available disk was used. With this update, extents can be provided for the disk size.
Clone Of:
Environment:
Last Closed: 2018-06-21 03:33:15 UTC
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1958 0 None None None 2018-06-21 03:34:48 UTC

Description Cal Calhoun 2017-12-08 15:53:23 UTC
Created attachment 1364945 [details]
gdeploy configuration file - gdeploy-no-backed-setup.conf

Description of problem:
  During manual creation of PVs, VGs and thin pools. gdeploy was failing until  size was added to the thinpool sections.  The docs indicate that the size option should be optional.

Version-Release number of selected component (if applicable):
  OS:      RHEL 7.4
  Kernel:  kernel-3.10.0-693.el7.x86_64 
  Gluster: glusterfs-server-3.8.4-44.el7rhgs
  gdeploy: gdeploy-2.0.2-14.el7rhgs.noarch

How reproducible:
  Completely

Steps to Reproduce:
  Using gdeploy-no-backed-setup.conf

  thinpool section:
  [lv1]
  action=create
  poolname=gluster_thinpool_vg0
  ignore_lv_errors=no
  vgname=gluster_vg0
  lvtype=thinpool
  poolmetadatasize=5GB

Actual results:
  failed: [172.16.3.2] (item={u'lv': u'gluster_thinpool_vg0', u'size': u'', u'extent': u'100%FREE', u'vg': u'gluster_vg0'}) => {"failed": true, "item": {"extent": "100%FREE", "lv": "gluster_thinpool_vg0", "size": "", "vg": "gluster_vg0"}, "msg": "  No command with matching syntax recognised.  Run 'lvcreate --help' for more information.\n  Nearest similar command has syntax:\n", "rc": 3}

Expected results:
  The "size" parameter should be optional according docs. AFAIK it should use all available space by default.

Additional info:
  SOSREPORTS: http://collab-shell.usersys.redhat.com/01973194/

Comment 2 Devyani Kota 2017-12-13 11:40:07 UTC
Cal,

I tried replicating what you were trying, with your attached config file.
I was able to create lvs without mentioning the size.
My config file is here[1].

I don't think it's because of the missing size parameter. Using 100% of the disk in case of missing size parameter is the default behaviour. Is there any way we can get access to this setup?

[1] https://paste.opensuse.org/41180366

Comment 6 Krist van Besien 2018-02-20 13:01:34 UTC
I am encountering exactly the same issue.

The config looks like this:

[lv1]
action=create
vgname=vg_gluster
poolname=lv_pool
lvtype=thinpool
poolmetadatasize=14G
chunksize=256k

This results in this error:


TASK [Create LVs with specified size for the VGs] **************************************************************
task path: /tmp/tmpEvupFJ/lvcreate.yml:7
failed: [exglus0003.it.rm.dk] (item={u'lv': u'lv_pool', u'size': u'', u'extent': u'100%FREE', u'vg': u'vg_gluster'}) => {"failed": true, "item": {"extent": "100%FREE", "lv": "lv_pool", "size": "", "vg": "vg_gluster"}, "msg": " No command with matching syntax recognised. Run 'lvcreate --help' for more information.\n Nearest similar command has syntax:\n", "rc": 3}
failed: [exglus0001.it.rm.dk] (item={u'lv': u'lv_pool', u'size': u'', u'extent': u'100%FREE', u'vg': u'vg_gluster'}) => {"failed": true, "item": {"extent": "100%FREE", "lv": "lv_pool", "size": "", "vg": "vg_gluster"}, "msg": " No command with matching syntax recognised. Run 'lvcreate --help' for more information.\n Nearest similar command has syntax:\n", "rc": 3}
failed: [exglus0002.it.rm.dk] (item={u'lv': u'lv_pool', u'size': u'', u'extent': u'100%FREE', u'vg': u'vg_gluster'}) => {"failed": true, "item": {"extent": "100%FREE", "lv": "lv_pool", "size": "", "vg": "vg_gluster"}, "msg": " No command with matching syntax recognised. Run 'lvcreate --help' for more information.\n Nearest similar command has syntax:\n", "rc": 3}
to retry, use: --limit @/tmp/tmpEvupFJ/lvcreate.retry


We reran it with "extents" added, and set to the exact number of PE on the PV. Gdeploy then ran.

Comment 27 errata-xmlrpc 2018-06-21 03:33:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1958


Note You need to log in before you can comment on or make changes to this bug.