Bug 152371 - X probelms if no network at boot
X probelms if no network at boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-28 17:26 EST by Bret Hughes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 21:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log when booting with no cable attached to Nic (32.21 KB, text/plain)
2005-03-29 16:03 EST, Bret Hughes
no flags Details
ps output when x is hung trying to bring up gdm login screen (2.41 KB, text/plain)
2005-03-29 16:04 EST, Bret Hughes
no flags Details

  None (edit)
Description Bret Hughes 2005-03-28 17:26:35 EST
Description of problem:
If eth0 is set up to be configured via dhcp and the network cable is
disconnected at boot, X does not start all the way. screen swithes to vt7 and a
black screen is presented with no keyboard input accepted.  This occurs if
booting into runlevel 5 or into 3 and running startx from a command prompt.


Version-Release number of selected component (if applicable):
same with xorg from the installation tree or if upgraded to latest from rawhide

How reproducible:
Always

Steps to Reproduce:
1. install FC4 t1 on mac mini
2. select workstation install
3. reboot
4. yum update gdm
5. reboot
6. yum install gnome-python2-gnomevfs
7. configure radeon 9200 card and monitor
8. unplug nic and reboot
  
Actual results:

X hangs at blank screen

Expected results:

X launch and gdm loging screen presented (rl 5) or desktop appear (rl 3 and startx)

Additional info:

THis occurs with gdm updated to rawhide and ati radeon 9200 selected at 1024 x
768 and generic LCD 1024 x 768 screen as monitor.  I have not tried it with no
packages updated/installed.

I do not know if this is related or not but selecting desktop->logout takes over
a minute to show the logout dialog.
Comment 1 Bret Hughes 2005-03-29 16:03:15 EST
Created attachment 112430 [details]
Xorg log when booting with no cable attached to Nic
Comment 2 Bret Hughes 2005-03-29 16:04:30 EST
Created attachment 112431 [details]
ps output when x is hung trying to bring up gdm login screen
Comment 3 Mike A. Harris 2005-04-11 06:55:43 EDT
This problem most likely is caused due to the way Xauthority works.

You must have a valid hostname, and the hostname can not change while X
is running.  This is a hard limitation of the current X11 implementation,
and it's unfortunately been this way for a long time.

It's more of a misfortunate design than it is a bug, however it does need
to be addressed eventually, but by X.Org directly, and not in an OS
distribution specific manner.

Please file a bug report in X.Org bugzilla to track this issue,
which is located at http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your report to X.Org, if you paste the URL here,
Red Hat will track the issue in X.Org bugzilla with upstream developers,
and will review any fixes that become available for potential inclusion
in future Fedora Core updates.

Comment 4 Mike A. Harris 2005-04-11 06:56:18 EDT
Setting status to "NEEDINFO", awaiting upstream bug URL for tracking.
Comment 5 Mike A. Harris 2005-05-04 21:24:08 EDT
If an upstream bug report has been filed for this issue, and you'd like
the X Devel team to track it for fixes, please update the bug with the
upstream bug URL, and reopen the bug and we will add it to our internal
tracker.

Setting status to WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.