Bug 1523778 - Understanding Failed Scheduling Predicates in `oc describe` is hard.
Summary: Understanding Failed Scheduling Predicates in `oc describe` is hard.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.10.0
Assignee: Avesh Agarwal
QA Contact: weiwei jiang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-08 17:29 UTC by Eric Paris
Modified: 2018-12-20 21:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-20 21:09:40 UTC


Attachments (Terms of Use)

Description Eric Paris 2017-12-08 17:29:44 UTC
I have a pod with a node selector that doesn't match any nodes. In `oc describe` the message I get is:

  17m		4m		48	default-scheduler			Warning		FailedScheduling	0/98 nodes are available: 82 Insufficient memory, 98 MatchNodeSelector.


If I read this it says 0/98 nodes are available.
There is Insufficient Memory on 82 of those 98 nodes.
98 of those nodes match my node selector.

I would like that text to change to
(a) use human readable words (MatchNodeSelector should be "match NodeSelector")
(b) include a negation ("98 Do not match NodeSelector") or ("0 match NodeSelector)

Comment 1 Seth Jennings 2017-12-08 21:38:08 UTC
Avesh, PTAL.

Comment 2 Avesh Agarwal 2017-12-11 17:51:48 UTC
(In reply to Eric Paris from comment #0)
> I have a pod with a node selector that doesn't match any nodes. In `oc
> describe` the message I get is:
> 
>   17m		4m		48	default-scheduler			Warning		FailedScheduling	0/98 nodes are
> available: 82 Insufficient memory, 98 MatchNodeSelector.
> 
> 
> If I read this it says 0/98 nodes are available.
> There is Insufficient Memory on 82 of those 98 nodes.
> 98 of those nodes match my node selector.
> 
> I would like that text to change to
> (a) use human readable words (MatchNodeSelector should be "match
> NodeSelector")
> (b) include a negation ("98 Do not match NodeSelector") or ("0 match
> NodeSelector)

Sgtm. will send something to kube upstream.

Comment 3 Seth Jennings 2018-04-27 16:53:37 UTC
This is already been done upstream for 1.10:
https://github.com/kubernetes/kubernetes/pull/58999

We should have this in 3.10 via the rebase.

Comment 7 weiwei jiang 2018-05-02 06:25:46 UTC
Checked on 
atomic-openshift-3.9.27-1.git.0.964617d.el7

and the issue is not fixed yet.

Comment 8 Seth Jennings 2018-05-02 14:39:51 UTC
Sorry, target release was wrong.  Fixed in 3.10.

Comment 12 weiwei jiang 2018-06-05 07:17:45 UTC
Checked with 
# oc version 
oc v3.10.0-0.58.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-wjiang-310r5-2-master-etcd-1:8443
openshift v3.10.0-0.58.0
kubernetes v1.10.0+b81c8f8

And the issue should be fixed 
  Warning  FailedScheduling  11s (x6 over 26s)  default-scheduler  0/2 nodes are available: 2 Insufficient cpu.
  Warning  FailedScheduling  14s (x6 over 29s)  default-scheduler  0/2 nodes are available: 2 node(s) didn't have free ports for the requested pod ports.


Note You need to log in before you can comment on or make changes to this bug.