Bug 152379 - cpufreq broken on iBook G4 with 2.6.11-1.1208_FC4
cpufreq broken on iBook G4 with 2.6.11-1.1208_FC4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-28 20:24 EST by Andrew Overholt
Modified: 2015-01-04 17:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-02 13:35:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2005-03-28 20:24:09 EST
Description of problem:
cpufreq was working with earlier rawhide kernels such as
kernel-2.6.11-1.1177_FC4 but now does not.  This is on my iBook G4 running a mix
of FC3 and rawhide.

$ cat /proc/cpuinfo
processor       : 0
cpu             : 7447A, altivec supported
clock           : 1066MHz
revision        : 1.1 (pvr 8003 0101)
bogomips        : 530.43
machine         : PowerBook6,5
motherboard     : PowerBook6,5 MacRISC3 Power Macintosh 
detected as     : 287 (iBook G4)
pmac flags      : 0000001b
L2 cache        : 512K unified
memory          : 768MB
pmac-generation : NewWorld

Version-Release number of selected component (if applicable):
2.6.11-1.1208_FC4

How reproducible:
Always

Steps to Reproduce:
1. cpufreq-info
  
Actual results:
analyzing CPU 0:
  no or unknown cpufreq driver is active on this CPU

Expected results:


Additional info:
Comment 1 shrek-m 2005-03-29 14:52:28 EST
same here, powerbook g4 12"  666/1333 MHz
fc4t1 clean install --> rawhide

with kernel-2.6.11-1.1208_FC4.ppc  cpufreq is always at 1333MHz

# cpuspeed
Error: Could not open file for writing:
/sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
Error: No such file or directory

$ uptime
 21:19:03 up 38 min,  4 users,  load average: 0.02, 0.22, 0.42
$ cat /proc/cpuinfo
processor       : 0
cpu             : 7447A, altivec supported
clock           : 1333MHz
revision        : 1.1 (pvr 8003 0101)
bogomips        : 663.55
machine         : PowerBook6,4
motherboard     : PowerBook6,4 MacRISC3 Power Macintosh
detected as     : 287 (PowerBook G4 12")
pmac flags      : 0000001a
L2 cache        : 512K unified
memory          : 768MB
pmac-generation : NewWorld


the cpufreq-applet tells me
"cpu frequency scaling unsupported -
you will not be able to modify the frequency of your machine. your machine may
be misconfigured or not have hardware support for cpu frequency scaling."

the applet shows "-848051MHz"
a new added applet shows "-1526131MHz"
booting into kernel-2.6.11-1.1177_FC4.ppc and all is ok "666MHz / 1,3 GHz"
Comment 2 shrek-m 2005-04-02 12:06:41 EST
thanks, here is all ok now.

$ uname -rmp
2.6.11-1.1219_FC4 ppc ppc

$ LANG=C cpufreq-info
cpufrequtils 0.2: cpufreq-info (C) Dominik Brodowski 2004
Report errors and bugs to linux@brodo.de, please.
analyzing CPU 0:
  driver: powermac
  CPUs which need to switch frequency at the same time: 0
  hardware limits: 667 MHz - 1.33 GHz
  available cpufreq governors: userspace, performance
  current policy: frequency should be within 667 MHz and 1.33 GHz.
                  The governor "userspace" may decide which speed to use
                  within this range.
  current CPU frequency is 667 MHz.
Comment 3 Andrew Overholt 2005-04-02 13:35:17 EST
Yup, this works for me now:  2.6.11-1.1225_FC4.

Closing RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.