Bug 152380 - glxinfo and 3-D apps segmentation faults
glxinfo and 3-D apps segmentation faults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-28 20:28 EST by Deji
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-16 17:47:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (41.29 KB, text/plain)
2005-03-28 20:28 EST, Deji
no flags Details
xorg.conf (2.81 KB, text/plain)
2005-03-28 20:30 EST, Deji
no flags Details

  None (edit)
Description Deji 2005-03-28 20:28:56 EST
Description of problem: Running glxinfo or ppracer produces segmentation fault.



Version-Release number of selected component (if applicable):xorg-x11-6.8.2-13


How reproducible: always


Steps to Reproduce:
1. run glxinfo, or
2. run ppracer
3.
  
Actual results:
libGL warning: 3D driver claims to not support visual 0x24
libGL warning: 3D driver claims to not support visual 0x28
libGL warning: 3D driver claims to not support visual 0x2c
libGL warning: 3D driver claims to not support visual 0x30
Segmentation fault

Expected results:
should produce the glx info

Additional info: I do have a rage 128 pro video card
Comment 1 Deji 2005-03-28 20:28:56 EST
Created attachment 112404 [details]
Xorg log file
Comment 2 Deji 2005-03-28 20:30:01 EST
Created attachment 112405 [details]
xorg.conf
Comment 3 Mike A. Harris 2005-04-11 06:57:58 EDT
Please file a bug report in X.Org bugzilla to track this issue,
which is located at http://bugs.freedesktop.org in the "xorg" component.

Once you've filed your report to X.Org, if you paste the URL here,
Red Hat will track the issue in X.Org bugzilla with upstream developers,
and will review any fixes that become available for potential inclusion
in future Fedora Core updates.
Comment 4 Mike A. Harris 2005-04-11 06:58:47 EDT
Setting status to "NEEDINFO", awaiting upstream bug URL for tracking.
Comment 5 Mike A. Harris 2005-05-16 17:47:33 EDT
We requested an upstream bug report to be filed for this issue just
over a month ago now, and have not heard any response since then so
I assume the problem no longer exists, or that it was a transient
issue.  If the problem still exists however, after updating to the
latest Fedora Core updates, and you would like Red Hat to track the
issue, follow the steps outlined in comment #3 above, and the official
R128 driver maintainers will be notified and can investigate the
issue.

Setting status to "RAWHIDE", assuming problem no longer exists due
to lack of response to inquiries.

Note You need to log in before you can comment on or make changes to this bug.