Bug 152383 - missing qt-devel docs
missing qt-devel docs
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: qt (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-28 21:17 EST by Demosthenes T. Mateo Jr.
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 16:27:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Demosthenes T. Mateo Jr. 2005-03-28 21:17:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1 Red Hat/1.0.1-1.4.3

Description of problem:
If you run qt designer and hit F1, the help file should be displayed. Instead, you will get a lot of pop-up window error messages and finally this:

The page could not be found!
'/usr/lib/qt-3.3/doc/html/designer-manual.html'



Version-Release number of selected component (if applicable):
qt-devel-3.3.3-9.3

How reproducible:
Always

Steps to Reproduce:
1. Run qt designer
2. Hit F1
3.
  

Actual Results:  Several pop-up window error messages and a finally error message which says

The page could not be found!
'/usr/lib/qt-3.3/doc/html/designer-manual.html'

Expected Results:  Help should have been displayed.

Additional info:

This can be fixed by adding a link as follows:

ln -s /usr/share/doc/qt-devel-3.3.3/ /usr/lib/qt-3.3/doc
Comment 1 Demosthenes T. Mateo Jr. 2005-03-28 21:19:39 EST
It looks like the qt-devel rpm package forgot to add the link becuase on a RHEL
3 system, the doc symlink is owned by the same package.
Comment 2 Ngo Than 2005-04-05 16:27:19 EDT
there's unfortunately a bug in qt-devel in fc2/fc3 which caused the file
conflict by update from RHEL3 to RHEL4 if this symlink included in qt-devel package!

It's now not possible to add this symlink back in qt-devel. A workaround is to add 
ln -s /usr/share/doc/qt-devel-3.3.3/ /usr/lib/qt-3.3/doc in %post.

Note You need to log in before you can comment on or make changes to this bug.