Bug 152390 - Pybliographer crashs on start
Pybliographer crashs on start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pybliographer (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Zoltan Kota
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 00:52 EST by Zuirdj
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-05 07:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuirdj 2005-03-29 00:52:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2 Fedora/1.0.2-2

Description of problem:
When I tried to run Pybliographer from menu or from command line, it simply refuses to work.

Traceback (most recent call last):
  File "/usr/bin/pybliographer", line 151, in ?
    execfile (filename, user_global)
  File "/usr/share/pybliographer/pybrc.py", line 5, in ?
    from Pyblio.TextUI import *
  File "/usr/share/pybliographer/Pyblio/TextUI.py", line 28, in ?
    from Pyblio import Base, Help, Search, Types, Autoload, Fields
  File "/usr/share/pybliographer/Pyblio/Base.py", line 31, in ?
    from Pyblio import Config, Open, Utils, Key, Iterator, Selection, Autoload
  File "/usr/share/pybliographer/Pyblio/Open.py", line 25, in ?
    from Pyblio import Autoload, Fields, Help, Exceptions
  File "/usr/share/pybliographer/Pyblio/Fields.py", line 24, in ?
    import copy, os, re, recode, string, time, types, urlparse
  File "/usr/share/pybliographer/Pyblio/recode.py", line 22, in ?
    import _recode
ImportError: No module named _recode

$ rpm -q recode
recode-3.6-16

Version-Release number of selected component (if applicable):
pybliographer-1.2.6.2-1

How reproducible:
Always

Steps to Reproduce:
1. Go to panel
2. Try to launch Pybliographer
3. Application doesn't start.
  

Additional info:
Comment 1 Zoltan Kota 2005-03-29 16:28:29 EST
python-bibtex provides the _recode module. Probably we need a rebuild for
python-bibtex due to a new python version in devel. (Re)build request is sent.
Let's see after rebuild...
Comment 2 Zoltan Kota 2005-04-05 07:15:20 EDT
python-bibtex is rebuilt in devel now. pybliographer should work.
Comment 3 Zuirdj 2005-04-05 13:13:39 EDT
It works OK now. Thanks for the hack.

Note You need to log in before you can comment on or make changes to this bug.