Bug 152391 - rhncfg-client produces error when relocating provisioned file to backup directory
Summary: rhncfg-client produces error when relocating provisioned file to backup direc...
Status: CLOSED DUPLICATE of bug 152449
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management   
(Show other bugs)
Version: unspecified
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nick Hansen
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-29 05:58 UTC by Dean Samuels
Modified: 2007-10-24 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 22:22:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dean Samuels 2005-03-29 05:58:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
New version of rhncfg-client (3.2-31) apparently relocates a the original/current version of the file being provisioned to the /var/lib/rhncfg/backups/<path_to_file> directory.  However, if the file being provisioned and backed up is on a separate filesystem to /var then the relocation will fail with a "OSError: [Errno 18] Invalid cross-device link
" traceback error.  This error is generally seen when trying to create a hard link to a file where the new hard link is on a different filesystem/partition to the original link/file.  

Version-Release number of selected component (if applicable):
rhncfg-client-3.2-31

How reproducible:
Always

Steps to Reproduce:
1.  Register system with RHN and config channels
2.  Download a provisioned file with rhncfg-client get <file>
3.  If file is on a separate partition to /var/lib/rhncfg/backups then hard link error occurs
  

Actual Results:  Error message occurs whenever provisioned file exists on local system and on a file system that is on a separate partition to the partition/filesystem that the /var/lib/rhncfg/backups directory is on, most likely a /var filesystem.

Expected Results:  Regardless of the partition/filesystem the provisioned file is on the original/current version should be relocated/moved to /var/lib/rhncfg/backups with a system call similar to what the mv command uses rather than trying to create a hard link (ie ln command) first.

Additional info:

Comment 1 Nick Hansen 2005-03-30 22:22:44 UTC
Dean, thanks for the bug report. THis bug is actually being tracked as a
customer issue. I'm closing this one as it is a dup. 

*** This bug has been marked as a duplicate of 152449 ***

Comment 2 Nick Hansen 2005-03-30 22:24:18 UTC
Also, this issue is fixed in the 3.2-32 version of the rhncfg pacakges.


Note You need to log in before you can comment on or make changes to this bug.