Bug 15240 - Upgrade RH6.2 > pinstripe fubars Boot Sector
Upgrade RH6.2 > pinstripe fubars Boot Sector
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: lilo (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 11:23 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-01 10:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-03 11:23:37 EDT
After upgrading my system from RH6.2, and electing *not* to change the
partition table or re-run lilo during the install process, lilo fails with
a 'LI' prompt at reboot. I was (and am) running kernel 2.2.16,
custom-built.
Comment 1 Alan Cox 2000-08-04 21:27:34 EDT
Since the kernel is replaced that is what I would expect to occur. 
I hesitate to class this as notabug, its too like a trap..
Comment 2 SharpFang 2000-09-01 10:19:19 EDT
Known behavior but definitely undesired. Lilo should at least arrive at LILO
boot: prompt if kernel has moved, and fail only upon attempting to load the
invalid image - still allowing to load different 'failsafe', 'dos' or similar
custom images.
Comment 3 Doug Ledford 2000-09-01 22:10:00 EDT
It's not the kernel change that is blowing things up, it's the upgrade to lilo
itself and the fact that the old lilo second stage boot loader is gone and the
new one has not been mapped out for the boot sector code.  It may seem like a
trap, but it's also unreasonable to expect that you can remove and reinstall
lilo without at least running it once on the old config file to remap things. 
Not-A-Bug.

Note You need to log in before you can comment on or make changes to this bug.