This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 152423 - yum update hangs after retrieval of repository files
yum update hangs after retrieval of repository files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 07:55 EST by Michael B. Weiner
Modified: 2014-01-21 17:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 08:47:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Yum update output (103.93 KB, text/plain)
2005-03-29 13:28 EST, Michael B. Weiner
no flags Details
Network is active...but some programs tell the opposite! (488.42 KB, image/png)
2005-03-29 17:52 EST, Marco
no flags Details

  None (edit)
Description Michael B. Weiner 2005-03-29 07:55:13 EST
Description of problem:
After an upgrade FROM FC3 TO FC4T1, yum upgrade fails to continue after retrieval of repository xml 
files.


Version-Release number of selected component (if applicable):
Tried with the vanilla yum version from fc4t1 and even with the newer version in development. Both 
versions hang after grabbing the repository data. 

How reproducible:
Do an upgrade from FC3 to FC4T1, reboot the machine once install has completed. Run yum check-
update and see that there are several packages to be updated from development repo. Run yum -y 
update and watch the repository data files be retrieved and it will sit and hang for hours until you issue 
a SIGKILL.

Steps to Reproduce:
1.  Do an upgrade from FC3 to FC4T1, reboot the machine once install has completed.
2.  Run yum check-update and see that there are several packages to be updated from development 
repo.
3. Run yum -y update and watch the repository data files be retrieved and it will sit and hang for hours 
until you issue a SIGKILL.
  
Actual results:
Same as described above

Expected results:
Yum to update the necessary packages to bring the install up to the level of development repository for 
FC4T1.

Additional info:
Comment 1 Seth Vidal 2005-03-29 09:07:58 EST
can you attach a 'yum -d 5 update' output?
Comment 2 Seth Vidal 2005-03-29 10:43:13 EST
This isn't a high severity problem. It's not happening all over.
Comment 3 Michael B. Weiner 2005-03-29 10:58:01 EST
thats part of the problem, NO I CANNOT, it hangs forever and no output to
console. Any suggestions? How about i blow away all the repository xml files and
re-try? Although i have done this already numerous times...something is
definitely afoot at the circle K. The issue is critical to me as i will be doing
this to over 600 servers to upgrade from rh73 to fcX - and if fc4 isnt useable
.... you get the drift

Michael Weiner
Comment 4 Seth Vidal 2005-03-29 10:59:46 EST
so you run:
yum -d5 update and you get NO OUTPUT AT ALL?

nothing.
not even the outputting of the yum version, nada?
Comment 6 Marco 2005-03-29 11:29:12 EST
I forgot: My Fedora Core 4 was a clean install
Comment 7 Michael B. Weiner 2005-03-29 12:20:12 EST
i get absolutely NO OUTPUT whatsoever, it sits and hangs after reporting on the
development repository, and will hang until killed - doesnt appear to zombie
however, so this behavior is a little strange.
Comment 8 Seth Vidal 2005-03-29 13:16:52 EST
Comment number 5: try two things:

1. cd /var/lib/rpm ; rm __db*
2. rpm --rebuilddb
3. re run yum

comment number 7: run this:
python -c 'import yum; my=yum.YumBase()'

and tell me what it does.

thanks.
Comment 9 Michael B. Weiner 2005-03-29 13:28:43 EST
Created attachment 112421 [details]
Yum update output

this is the output after waiting about 2 hours or so
Comment 10 Seth Vidal 2005-03-29 13:58:50 EST
Follow the instructions here:
http://www.fedorafaq.org/fc2/#mozillaipv6

and see if yum becomes much more responsive.

Also how much/little ram do you have?
Comment 11 Michael B. Weiner 2005-03-29 17:06:00 EST
Its a Sony Vaio PCG-F480 with 256M RAM and 512M Swap (i know i know, its rather slow, lol) Trying 
the faq instruction now.
Comment 12 Michael B. Weiner 2005-03-29 17:15:59 EST
okid disabled ipv6 (not having ipv6 enabled and running makes me curious why we feel this would 
improve yum's performance), rebooted, ran yum -d5 update (this is yum-2.3.1-3) and the output is as 
follows:

Yum Version 2.3.1
COMMAND: yum -d5 update
Installroot: /
Setting up Update Process
Setting up Repos
Baseurl(s) for repo:['http://download.fedora.redhat.com/pub/fedora/linux/core/development/
i386','http://mirror.hiwaay.net/redhatfedora/linux/core/development/i386/','http://
mirrors.kernel.org/fedora/core/development/i386/','http://distro.ibiblio.org/publinux/distributions/
fedora/linux/core/development/i386/']
development          100% |======================| 1.1kB    00:00
Reading repository metadata in from local files
Setting up Package Sacks
Excluding Incomaptible Archs
Finished
Reading Local RPMDB
Building updates object

and there it hangs.....still

Michael Weiner
Comment 13 Michael B. Weiner 2005-03-29 17:43:48 EST
Btw the import of YumBase() works fine, no errors nor tracebacks come back.
Comment 14 Marco 2005-03-29 17:45:50 EST
(In reply to comment #8) 
> Comment number 5: try two things: 
>  
> 1. cd /var/lib/rpm ; rm __db* 
> 2. rpm --rebuilddb 
> 3. re run yum 
 
Same thing...this is after I have done the 3-steps and turned off ipv6. 
I've an Athlon64 3000+ with 1 GB of ram. 
I've also some other strange things: my network (nforce4's net on board, I've 
a MSI K8N Platinum) works ok, however I cannot go to the internet, but see my 
attachment. 
Is it related? 
 
Thanx for help! 
 
Comment 15 Marco 2005-03-29 17:52:21 EST
Created attachment 112435 [details]
Network is active...but some programs tell the opposite!
Comment 16 Michael B. Weiner 2005-03-29 18:46:09 EST
Well, not wanting to, but in an effor to help debug, i blew away the rpm db files and regenerated them, 
and then tried to re-run yum (yum -y update). Interestingly enough, after running the --rebuilddb the 
dbs were created then removed from the system. Bottom line is THAT SEEMED TO FIX THE ISSUE for me. 
Waiting for it complete, to report the final results, but its further along than it was prior to the removal 
and reconstruction of the rpm db.

Additional, unrelated question however, isnt it better to do a rpmdb --rebuild rather than rpm --
rebuilddb ? Or is one a wrapper around the other?

Michael Weiner
Comment 17 Michael B. Weiner 2005-03-29 18:57:43 EST
the yum -y update completed, transactions failed due to a slew of deps but it DID complete as 
expected. Now to work through the tide of errors on deps, its a rather lenghty list, as illustrated in my 
attacment # 112421 (617 packages flagged to be updated, with a bunch of deps) does that sound 
about right? 

Michael Weiner
Comment 18 Seth Vidal 2005-03-30 00:49:47 EST
Comment #17:
you got dep errors? Are you sure they were dependencies? Yum doesn't allow an
unresolved transaction to execute.

Comment #12: 
 We've seen that some systems with ipv6 enabled will stall out trying to resolve
the AAAA record of their repositories. It's happened repeatedly, mostly due to
misconfigured dns.

Comment #16: pretty sure it's the same program just wrapped differently.

Comment #15: I think you've got some network problems to address first. Please
make sure you're able to contact all of your repositories and/or mirrorlists in
your yum .repo files via a web browser first.

Thanks
Comment 19 Marco 2005-03-30 06:43:13 EST
(In reply to comment #18)
> Comment #15: I think you've got some network problems to address first. Please
> make sure you're able to contact all of your repositories and/or mirrorlists in
> your yum .repo files via a web browser first.

Today yum works for the first time, no change from yesterday!
But for my situation about network can you help me?
Comment 20 Marco 2005-03-30 06:47:05 EST
It works for 5 minutes and stops......but yum uses some port? I have a router,
should I have to open some port?
Comment 21 Marco 2005-03-30 06:57:21 EST
Ok sometimes works sometimes not, sometimes I can reach via browser
http://fedora.redhat.com/download/mirrors/fedora-core-rawhide sometimes not.

Sometimes i can use yum with connection immediately, sometimes I wait for 20
minutes without a response.

Can be related to my network situation?
Comment 22 Seth Vidal 2005-03-30 08:45:33 EST
Marco: it's entirely related to your network situation. I'd suggest refiling a
bug about your network card against the kernel.

Comment 23 Seth Vidal 2005-03-30 08:47:39 EST
oh and unless either of you thinks this is unclosed. I'm going to close it notabug.
Comment 24 Marco 2005-03-30 09:08:54 EST
Ok if you want to help go to:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=152566

(In reply to comment #23)
> oh and unless either of you thinks this is unclosed. I'm going to close it
notabug.


Note You need to log in before you can comment on or make changes to this bug.