Bug 152445 - flac-1.1.2-1 depends on an old version of itself, can't be installed
flac-1.1.2-1 depends on an old version of itself, can't be installed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: flac (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 11:42 EST by John Thacker
Modified: 2013-03-13 00:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 15:50:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Thacker 2005-03-29 11:42:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2 Fedora/1.0.2-2

Description of problem:
flac-1.1.2-1, just added to rawhide, picked up a dependency against its own older version when being built in rawhide.  (An annoying problem, but one I've seen before.)  As a result, the package depends on libFLAC.so.4 and can't be installed, since it doesn't provide libFLAC.so.4 but rather libFLAC.so.7  It needs to be rebuilt again so that it picks up its own proper dependencies and can be installed.

Version-Release number of selected component (if applicable):
flac-1.1.2-1

How reproducible:
Always

Steps to Reproduce:
1.  rpm -Uvh flac-1.1.2-1.i386.rpm, or
2.  yum install flac
  

Actual Results:  It won't install, with an error like:
Error: Missing Dependency: libFLAC.so.4 is needed by package flac


Expected Results:  It should install.

Additional info:
Comment 1 John (J5) Palmieri 2005-03-29 15:50:47 EST
recompiled

Note You need to log in before you can comment on or make changes to this bug.