Bug 1524465 - [RHGSWA] TPS test for SRPM is failing for 'dist' usage at the spec file of pysnmi & pysnmp
Summary: [RHGSWA] TPS test for SRPM is failing for 'dist' usage at the spec file of py...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-ui
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: Filip Balák
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-11 15:02 UTC by Vivek Das
Modified: 2017-12-18 04:38 UTC (History)
5 users (show)

Fixed In Version: pysnmp-4.3.10-3.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:38:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1522773 None None None 2019-09-10 14:42:26 UTC
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC

Internal Links: 1522773

Description Vivek Das 2017-12-11 15:02:46 UTC
Description of problem:

The dist tag standards isn't used properly, in the spec file of 'pysmi' & 'pysnmp' as the TPS SRPM tests are failing.

DIST CHECK: %{dist} found instead of %{?dist} in: pysmi-0.2.1-1.el7rhgs.src.rpm.spec
Release string was: 1%{dist}
DIST CHECK: %{dist} found instead of %{?dist} in: pysnmp-4.3.10-1.el7rhgs.src.rpm.spec
Release string was: 1%{dist}

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Filip Balák 2017-12-12 08:43:40 UTC
Looks ok. --> VERIFIED

Tested with:
hwinfo-20.2-5.4.el7rhgs.src.rpm
liboping-1.6.2-2.2.el7rhgs.src.rpm
libx86emu-1.1-22.1.2.2.el7rhgs.src.rpm
pysmi-0.2.1-2.el7rhgs.src.rpm
pysnmp-4.3.10-3.el7rhgs.src.rpm
python-etcd-0.4.5-2.el7rhgs.src.rpm
python-simplejson-3.5.3-5.1.el7rhgs.src.rpm
python-typing-3.5.2.2-2.2.el7rhgs.src.rpm
python-ruamel-ordereddict-0.4.9-3.1.el7rhgs.src.rpm
rubygem-activesupport-4.2.6-2.el7rhgs.src.rpm
rubygem-etcd-0.3.0-2.el7rhgs.src.rpm
rubygem-i18n-0.7.0-2.el7rhgs.src.rpm
rubygem-minitest-5.9.1-2.el7rhgs.src.rpm
rubygem-mixlib-log-1.7.1-2.el7rhgs.src.rpm
rubygem-puma-3.6.0-2.el7rhgs.src.rpm
rubygem-rack-1.6.4-2.el7rhgs.src.rpm
rubygem-rack-protection-1.5.3-2.el7rhgs.src.rpm
rubygem-rake-0.9.6-2.el7rhgs.src.rpm
rubygem-sinatra-1.4.5-2.el7rhgs.src.rpm
rubygem-thread_safe-0.3.5-3.el7rhgs.src.rpm
rubygem-tilt-1.4.1-4.el7rhgs.src.rpm
rubygem-tzinfo-1.2.2-2.1.el7rhgs.src.rpm

Comment 5 errata-xmlrpc 2017-12-18 04:38:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.