Bug 1524781 - creation of gluster block storage class fails with file not found
Summary: creation of gluster block storage class fails with file not found
Keywords:
Status: CLOSED DUPLICATE of bug 1517225
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-12 03:27 UTC by raffaele spazzoli
Modified: 2017-12-12 15:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-12 15:02:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description raffaele spazzoli 2017-12-12 03:27:36 UTC
installer seems not to be able to find the storage class template:

TASK [openshift_storage_glusterfs : Copy initial glusterblock provisioner resource file] **************************************************************************************************************************
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: 	/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-glusterfs/../../common/openshift-glusterfs/v3.7/glusterblock-template.yml
failed: [master1] (item=glusterblock-template.yml) => {"changed": false, "failed": true, "item": "glusterblock-template.yml", "msg": "Could not find or access 'v3.7/glusterblock-template.yml'\nSearched in:\n\t/usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/files/v3.7/glusterblock-template.yml\n\t/usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/v3.7/glusterblock-template.yml\n\t/usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/tasks/files/v3.7/glusterblock-template.yml\n\t/usr/share/ansible/openshift-ansible/roles/openshift_storage_glusterfs/tasks/v3.7/glusterblock-template.yml\n\t/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-glusterfs/../../common/openshift-glusterfs/files/v3.7/glusterblock-template.yml\n\t/usr/share/ansible/openshift-ansible/playbooks/byo/openshift-glusterfs/../../common/openshift-glusterfs/v3.7/glusterblock-template.yml"}

In fact that file does not exists.

Comment 1 Jaspreet Kaur 2017-12-12 10:10:10 UTC
which verison of openshift-ansible is there ?
 
rpm -qa | grep openshift-ansible 

In below version it looks for glusterblock-provisioner.yml instead of glusterblock-template.yml:

openshift-ansible-lookup-plugins-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-roles-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-filter-plugins-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-docs-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-callback-plugins-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-playbooks-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-3.7.9-1.git.7.eedd332.el7.noarch

Comment 2 raffaele spazzoli 2017-12-12 13:46:33 UTC
here it is:

[rspazzol@ose-bastion ~]$ rpm -qa | grep openshift-ansible
openshift-ansible-lookup-plugins-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-callback-plugins-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-filter-plugins-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-playbooks-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-docs-3.7.9-1.git.7.eedd332.el7.noarch
openshift-ansible-roles-3.7.9-1.git.7.eedd332.el7.noarch


so it looks like we have the same version

Comment 3 Scott Dodson 2017-12-12 15:02:05 UTC

*** This bug has been marked as a duplicate of bug 1517225 ***


Note You need to log in before you can comment on or make changes to this bug.