Bug 1524785 - [RHEL-7.5] Unable to finish Network & Host Name settings in graphical initial-setup
Summary: [RHEL-7.5] Unable to finish Network & Host Name settings in graphical initial...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Martin Kolman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1530682
TreeView+ depends on / blocked
 
Reported: 2017-12-12 04:02 UTC by Qiaowei Zheng
Modified: 2018-04-10 08:49 UTC (History)
14 users (show)

Fixed In Version: anaconda-21.48.22.130-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1530682 (view as bug list)
Environment:
Last Closed: 2018-04-10 08:47:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
/var/log/messages log file (983.87 KB, text/plain)
2017-12-14 05:46 UTC, Qiaowei Zheng
no flags Details
/var/log/dmesg log file (38.53 KB, text/plain)
2017-12-14 05:47 UTC, Qiaowei Zheng
no flags Details
" journalctl -u NetworkManager " output (18.72 KB, text/x-vhdl)
2017-12-14 05:48 UTC, Qiaowei Zheng
no flags Details
journalctl output (181.39 KB, text/x-vhdl)
2017-12-14 07:08 UTC, Qiaowei Zheng
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0671 None None None 2018-04-10 08:49:06 UTC

Description Qiaowei Zheng 2017-12-12 04:02:31 UTC
Description of problem:
    In hyper-v guest, after doing modifications in network & Host Name settings in initial-setup of Server with GUI installation, clicking "Done" button does not finish "NETWORK & HOST NAME" setting. Initial-setup unable to proceed.

Version-Release number of selected component (if applicable):
Hyper-V Generation 1 Guest
Windows Server 2016 Hyper-V Host


How reproducible:
100%

Steps to Reproduce:
1. Create a vm guest on 2016 hyper-v host, in "Network Adapter" settings, choose External.
2. Install RHEL7.5 from iso image, choose "Server with GUI" package
3. After installation finished, reboot machine and enter initial-setup
4. Click " NETWORK & HOST NAME", turn on eth0
5. Click "Done" to finish Network settings.

Actual results:
GUI does not finish Network settings after clicking "Done".

Expected results:
Network settings finishes and proceed with initial-setup.

Additional info:
1. This issue exists in RHEL7.5 20171107/20171130/20171203(nightly) buids.
2. If RHEL7.5 with GUI has been installed and skipped network settings in initial-setup, use following command to re-enable firstboot and reproduce this issue.
# systemctl enable initial-setup-graphical.service
3. After entered "NETWORK & HOST NAME" settings, if you modify nothing and click "Done",

Comment 2 Qiaowei Zheng 2017-12-12 04:06:47 UTC
After entered "NETWORK & HOST NAME" settings, if you modify nothing and click "Done", it will finish normally, and could proceed with initial-setup. This issue only occurs when settings has been modified.

Comment 5 Martin Kolman 2017-12-13 14:55:15 UTC
Please attach content of Journal from the affected system so that I can try to debug the issues. Initial Setup logs to Journal quite heavily and there might be other messages of interest as well (eq. from network manager, etc.).

Thanks in advance! :)

Comment 7 Qiaowei Zheng 2017-12-14 05:46:50 UTC
Created attachment 1367787 [details]
/var/log/messages log file

Comment 8 Qiaowei Zheng 2017-12-14 05:47:24 UTC
Created attachment 1367788 [details]
/var/log/dmesg log file

Comment 9 Qiaowei Zheng 2017-12-14 05:48:15 UTC
Created attachment 1367789 [details]
" journalctl -u NetworkManager " output

Comment 10 Qiaowei Zheng 2017-12-14 07:08:46 UTC
Created attachment 1367833 [details]
journalctl output

Comment 11 Martin Kolman 2018-01-03 16:41:34 UTC
PR: https://github.com/rhinstaller/anaconda/pull/1286

Comment 18 errata-xmlrpc 2018-04-10 08:47:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0671


Note You need to log in before you can comment on or make changes to this bug.