Bug 152500 - incomplete dependencies break pkgconfig dependency chain
Summary: incomplete dependencies break pkgconfig dependency chain
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libgnomecups (Show other bugs)
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-29 21:52 UTC by Michael Schwendt
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version: 0.2.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-13 20:48:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against CVS (379 bytes, patch)
2005-04-13 00:18 UTC, Michael Schwendt
no flags Details | Diff

Description Michael Schwendt 2005-03-29 21:52:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050323
Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Package libgnomecups-devel contains a pkgconfig template file, which lists other
pkgconfig files as requirements. When these files are included in other RPM
packages, the RPM package "Requires" must be complete. Else pkgconfig fails,
prints an error message and returns an error code for standard queries like
"pkg-config --exists foo-1.0", "pkg-config --cflags foo-1.0" or "pkg-config
--list-all".

missing dependencies due to pkgconfig files:

Requires: glib2-devel


Version-Release number of selected component (if applicable):
libgnomecups-devel-0.1.14-3

How reproducible:
Always

Steps to Reproduce:
-
    

Additional info:

Comment 1 Michael Schwendt 2005-04-13 00:18:38 UTC
Created attachment 113067 [details]
patch against CVS

Comment 2 David Zeuthen 2005-04-13 20:48:28 UTC
Thanks for the patch; I've applied it.


Note You need to log in before you can comment on or make changes to this bug.