Bug 152505 - incomplete dependencies break pkgconfig dependency chain
Summary: incomplete dependencies break pkgconfig dependency chain
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus-cd-burner   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-29 22:01 UTC by Michael Schwendt
Modified: 2013-03-06 03:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-13 20:50:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against CVS (429 bytes, patch)
2005-04-13 00:25 UTC, Michael Schwendt
no flags Details | Diff

Description Michael Schwendt 2005-03-29 22:01:40 UTC
Package nautilus-cd-burner-devel contains a pkgconfig template file,
which lists other pkgconfig files as requirements. When these files
are included in other RPM packages, the RPM package "Requires" must be
complete. Else pkgconfig fails, prints an error message and returns an
error code for standard queries like "pkg-config --exists foo-1.0",
"pkg-config --cflags foo-1.0" or "pkg-config --list-all".

nautilus-cd-burner-devel-2.9.8-2.i386.rpm

missing dependencies due to pkgconfig files:

Requires: gtk2-devel

Comment 1 Michael Schwendt 2005-04-13 00:25:59 UTC
Created attachment 113071 [details]
patch against CVS

Comment 2 David Zeuthen 2005-04-13 20:50:00 UTC
Thanks for the patch, I've applied it to CVS but for some reason it won't build yet.

Comment 3 Roozbeh Pournader 2005-09-25 17:16:49 UTC
The build problem is in bug 157748.


Note You need to log in before you can comment on or make changes to this bug.