Bug 152509 - incomplete dependencies break pkgconfig dependency chain
Summary: incomplete dependencies break pkgconfig dependency chain
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pygobject2   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-29 22:03 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: pygobject2-2.12.2-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 02:30:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against CVS (371 bytes, patch)
2005-04-13 00:28 UTC, Michael Schwendt
no flags Details | Diff

Description Michael Schwendt 2005-03-29 22:03:07 UTC
Package pygtk2-devel contains a pkgconfig template file, which lists
other pkgconfig files as requirements. When these files are included
in other RPM packages, the RPM package "Requires" must be complete.
Else pkgconfig fails, prints an error message and returns an error
code for standard queries like "pkg-config --exists foo-1.0",
"pkg-config --cflags foo-1.0" or "pkg-config --list-all".

pygtk2-devel-2.6.0-2.i386.rpm

missing dependencies due to pkgconfig files:

Requires: glib2-devel

Comment 1 Michael Schwendt 2005-04-13 00:28:22 UTC
Created attachment 113072 [details]
patch against CVS

Comment 2 Matthew Barnes 2006-09-24 01:41:46 UTC
Thanks for the patch.  It look like this has since been fixed.  The latest
Rawhide release lists glib2-devel as a BuildRequires.  Closing this bug.

pygtk2-2.10.1-4.fc6

Comment 3 Michael Schwendt 2006-09-24 09:36:37 UTC
You are mistaken. BuildRequires glib2-devel would _not_ fix this,
since I do not refer to a problem at build-time, but to a problem
at run-time. I even provided a *patch* in comment 1!

But I've verified that

  pygtk2-devel-2.10.1-3.fc6

does not depend on glib2-devel anymore. Now it depends on pygobject2-devel
and in turn the breakage has relocated to pygobject2-devel.

$ cd /usr/lib/pkgconfig
$ grep Req pygtk-2.0.pc 
Requires: pygobject-2.0
$ grep Req pygobject-2.0.pc 
Requires: gobject-2.0
$ grep Req gobject-2.0.pc
grep: gobject-2.0.pc: No such file or directory

==> missing "Requires: glib2-devel" in package "pygobject2-devel"!

$ rpm -qR pygobject2-devel
pkgconfig  
pygobject2 = 2.12.1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

Comment 4 Matthias Clasen 2006-09-25 13:05:33 UTC
The only way to avoid this kind of problem reliable is to make rpm pick up
dependencies from .pc files. Anything else is just bandaids.

Comment 5 Matthew Barnes 2006-10-30 02:30:48 UTC
The pygobject2-devel package in Fedora Core 6 now requires glib2-devel (band-aid
though it may be), so I'm closing this bug.  Please feel free to reopen it if
you feel the problem has still not been addressed.


Note You need to log in before you can comment on or make changes to this bug.