Bug 152517 - Update callgrind to work with valgrind-2.4.0
Update callgrind to work with valgrind-2.4.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: valgrind-callgrind (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 17:48 EST by John Thacker
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 09:28:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Thacker 2005-03-29 17:48:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050325 Firefox/1.0.2 Fedora/1.0.2-2

Description of problem:
Valgrind was recently updated in rawhide to 2.4.0.  Callgrind in rawhide depends on valgrind 2.2.0, and so needs to be built against valgrind 2.4.0.

Possible problem:  Documentation on the callgrind webpage and in CVS seem to indicate that callgrind has not released a version which works with valgrind 2.4.0, although current CVS works with callgrind.  The project maintainer recommends using CVS.  I'm not sure if FC wants to use source from CVS, but this bug is being created at least as a placeholder for now.

Version-Release number of selected component (if applicable):
valgrind-callgrind-0.9.9-2

How reproducible:
Always

Steps to Reproduce:
1. yum install vallgrind
2. yum install vallgrind-callgrind
  

Actual Results:  Error messages like:
Error: Missing Dependency: valgrind = 1:2.2.0 is needed by package valgrind-callgrind

Expected Results:  callgrind should be installable

Additional info:
Comment 1 John Thacker 2005-03-31 09:28:07 EST
Looks like this is updated in rawhide.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.