Bug 1525196 - org.eclipse.jgit.api.errors.TransportException: REPOSITORYURL: timeout in waiting for rekeying process.
Summary: org.eclipse.jgit.api.errors.TransportException: REPOSITORYURL: timeout in wai...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-jgit
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mat Booth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-12 18:25 UTC by Alex Villacís Lasso
Modified: 2018-01-06 23:19 UTC (History)
7 users (show)

Fixed In Version: eclipse-jgit-4.9.1-2.fc26 eclipse-jgit-4.9.1-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-06 23:08:59 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Eclipse Project 526867 None None None 2017-12-12 18:30:03 UTC

Description Alex Villacís Lasso 2017-12-12 18:25:06 UTC
Description of problem:
Unable to do any remote operations on my bitbucket GIT repository through Eclipse GUI or using the jgit command. The git command runs correctly on the same repository. The Eclipse git interface worked correctly before the last update.

Version-Release number of selected component (if applicable):
jgit-4.9.0-2.fc27.noarch

How reproducible:
Always (on this repository).

Steps to Reproduce:
1. Enter into a bitbucket git repository
2. jgit --show-stack-trace push
3.

Actual results:
[alex@avillacis Call-Center-PRO]$ jgit --show-stack-trace push
org.eclipse.jgit.api.errors.TransportException: git@bitbucket.org:avillacis/dinomi-callcenterpro.git: timeout in waiting for rekeying process.
	at org.eclipse.jgit.api.PushCommand.call(PushCommand.java:180)
	at org.eclipse.jgit.pgm.Push.run(Push.java:136)
	at org.eclipse.jgit.pgm.TextBuiltin.execute(TextBuiltin.java:224)
	at org.eclipse.jgit.pgm.Main.execute(Main.java:275)
	at org.eclipse.jgit.pgm.Main.run(Main.java:163)
	at org.eclipse.jgit.pgm.Main.main(Main.java:135)
Caused by: org.eclipse.jgit.errors.TransportException: git@bitbucket.org:avillacis/dinomi-callcenterpro.git: timeout in waiting for rekeying process.
	at org.eclipse.jgit.transport.JschConfigSessionFactory.getSession(JschConfigSessionFactory.java:163)
	at org.eclipse.jgit.transport.SshTransport.getSession(SshTransport.java:137)
	at org.eclipse.jgit.transport.TransportGitSsh$SshPushConnection.<init>(TransportGitSsh.java:332)
	at org.eclipse.jgit.transport.TransportGitSsh.openPush(TransportGitSsh.java:174)
	at org.eclipse.jgit.transport.PushProcess.execute(PushProcess.java:160)
	at org.eclipse.jgit.transport.Transport.push(Transport.java:1310)
	at org.eclipse.jgit.api.PushCommand.call(PushCommand.java:169)
	... 5 more
Caused by: com.jcraft.jsch.JSchException: timeout in waiting for rekeying process.
	at com.jcraft.jsch.Session.write(Session.java:1354)
	at com.jcraft.jsch.Session.send_newkeys(Session.java:703)
	at com.jcraft.jsch.Session.connect(Session.java:355)
	at org.eclipse.jgit.transport.JschConfigSessionFactory.getSession(JschConfigSessionFactory.java:117)
	... 11 more


Expected results:
Operation should complete successfully

Additional info:
"git push" works correctly on the same repository, so this is not a network issue.

The jgit command does work correctly on github repositories...

Comment 1 Fedora Update System 2017-12-18 11:32:18 UTC
eclipse-webtools-3.9.2-1.fc27 eclipse-linuxtools-6.2.0-1.fc27 eclipse-dltk-5.8.2-1.fc27 eclipse-usage-4.5.2-0.1.fc27 eclipse-4.7.2-1.fc27 eclipse-recommenders-2.5.0-1.fc27 eclipse-mylyn-3.23.2-2.fc27 eclipse-dtp-1.14.1-1.fc27 eclipse-egit-4.9.1-1.fc27 eclipse-jgit-4.9.1-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2e1b714002

Comment 2 Fedora Update System 2017-12-18 11:32:37 UTC
eclipse-webtools-3.9.2-1.fc26 eclipse-linuxtools-6.2.0-1.fc26 eclipse-dltk-5.8.2-1.fc26 eclipse-4.7.2-1.fc26 eclipse-recommenders-2.5.0-1.fc26 eclipse-mylyn-3.23.2-2.fc26 eclipse-dtp-1.14.1-1.fc26 eclipse-egit-4.9.1-1.fc26 eclipse-jgit-4.9.1-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-3c602edc69

Comment 3 Fedora Update System 2017-12-18 22:01:56 UTC
eclipse-4.7.2-1.fc27, eclipse-dltk-5.8.2-1.fc27, eclipse-dtp-1.14.1-1.fc27, eclipse-egit-4.9.1-1.fc27, eclipse-jgit-4.9.1-2.fc27, eclipse-linuxtools-6.2.0-1.fc27, eclipse-mylyn-3.23.2-2.fc27, eclipse-recommenders-2.5.0-1.fc27, eclipse-usage-4.5.2-0.1.fc27, eclipse-webtools-3.9.2-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2e1b714002

Comment 4 Fedora Update System 2017-12-18 22:40:07 UTC
eclipse-4.7.2-1.fc26, eclipse-dltk-5.8.2-1.fc26, eclipse-dtp-1.14.1-1.fc26, eclipse-egit-4.9.1-1.fc26, eclipse-jgit-4.9.1-2.fc26, eclipse-linuxtools-6.2.0-1.fc26, eclipse-mylyn-3.23.2-2.fc26, eclipse-recommenders-2.5.0-1.fc26, eclipse-webtools-3.9.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-3c602edc69

Comment 5 Fedora Update System 2018-01-06 23:08:59 UTC
eclipse-4.7.2-1.fc26, eclipse-dltk-5.8.2-1.fc26, eclipse-dtp-1.14.1-1.fc26, eclipse-egit-4.9.1-1.fc26, eclipse-jgit-4.9.1-2.fc26, eclipse-linuxtools-6.2.0-1.fc26, eclipse-mylyn-3.23.2-2.fc26, eclipse-recommenders-2.5.0-1.fc26, eclipse-webtools-3.9.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2018-01-06 23:19:43 UTC
eclipse-4.7.2-1.fc27, eclipse-dltk-5.8.2-1.fc27, eclipse-dtp-1.14.1-1.fc27, eclipse-egit-4.9.1-1.fc27, eclipse-jgit-4.9.1-2.fc27, eclipse-linuxtools-6.2.0-1.fc27, eclipse-mylyn-3.23.2-2.fc27, eclipse-recommenders-2.5.0-1.fc27, eclipse-usage-4.5.2-0.1.fc27, eclipse-webtools-3.9.2-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.