Bug 152528 - "package <blah> is already installed"
"package <blah> is already installed"
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-29 20:27 EST by james
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 07:59:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description james 2005-03-29 20:27:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; X11; Linux i686) Opera 7.54  [en]

Description of problem:
rpm fails unnecessarily when "installing" an "already installed" package.  Why?

Say you have a shell-globbed list of packages, like "perl-*" that you want to 
install.  If some of those packages, the perl package itself say, are already 
installed, then the entire install fails.  Using the rpm option "--replacepkgs" 
is not very clever work-around, since then rpm will waste time "re-installing" 
an already installed package.

What damage is caused if rpm simply skips installing an already installed 
package by default, simply removes an "already installed" package from its list 
of packages to install?


Version-Release number of selected component (if applicable):
rpm-4.3.2-21

How reproducible:
Always

Steps to Reproduce:
1.rpm -ivh perl-*
2.
3.
  

Actual Results:  nothing useful

Expected Results:  the packages listed to be installed should all be installed by command 
completion.

Additional info:
Comment 1 Jeff Johnson 2005-11-04 07:59:27 EST
Skipping packages already installed leads to a degree of indeterminism that damages
users confidence. For example, "already installed" is imprecise. Does that mean that
there is already a package with than name-version-release installed? What if the names
are identical but the contents are not? Even if the contentys are identical, what if the
files on the file system have been changed?

Personally, I think rpm will eventually have to undertake the verification steps necessary
to attempt "best effort" skipping as you suggest. But right now most users are more
comfortable with the existing behavior.

Note You need to log in before you can comment on or make changes to this bug.