Bug 1525374 - EngineException: Failed to GetLldpVDS, error = The method does not exist / is not available when running a 3.6 host in rhv 4.2 engine
Summary: EngineException: Failed to GetLldpVDS, error = The method does not exist / is...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.0
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ovirt-4.2.1
: ---
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-13 08:30 UTC by Michael Burman
Modified: 2019-05-16 13:08 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 17:46:12 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)
engine log (413.54 KB, application/x-gzip)
2017-12-13 08:30 UTC, Michael Burman
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:47:48 UTC
oVirt gerrit 85493 0 master MERGED webadmin, core: Add check if LLDP is supported by VDSM 2020-07-27 07:48:59 UTC

Description Michael Burman 2017-12-13 08:30:23 UTC
Created attachment 1367174 [details]
engine log

Description of problem:
EngineException: Failed to GetLldpVDS, error = The method does not exist / is not available when running a 3.6 host in rhv 4.2 engine

There are engine exceptions when running a 3.6 host in rhv 4.2 engine:

2017-12-13 10:23:31,460+02 ERROR [org.ovirt.engine.core.bll.network.host.GetMultipleTlvsByHostIdQuery] (default task-1) [99da16fa-7739-42d8-88c6-31dba535e110] Query 'GetMultipleTlvsByHostIdQuery' failed: EngineExc
eption: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to GetLldpVDS, error = The method does not exist / is not available., code = -32601 (Failed with 
error unexpected and code 16)
2017-12-13 10:23:31,460+02 ERROR [org.ovirt.engine.core.bll.network.host.GetMultipleTlvsByHostIdQuery] (default task-1) [99da16fa-7739-42d8-88c6-31dba535e110] Exception: org.ovirt.engine.core.common.errors.EngineE
xception: EngineException: org.ovirt.engine.core.vdsbroker.vdsbroker.VDSErrorException: VDSGenericException: VDSErrorException: Failed to GetLldpVDS, error = The method does not exist / is not available., code = -
32601 (Failed with error unexpected and code 16)
        at org.ovirt.engine.core.bll.VdsHandler.handleVdsResult(VdsHandler.java:118) [bll.jar:]

- Note for my self - check if same happens when running 4.1 host in rhv 4.2

Version-Release number of selected component (if applicable):
4.2.0.2-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Add 3.6 host(latest) to rhv 4.2 engine

Actual results:
Exception regrading  GetLldpVDS in the engine log and in the event log ui

Expected results:
NO exception in the engine log

Comment 1 Dan Kenigsberg 2017-12-13 20:34:33 UTC
We must not attempt to read LLDP information when the host is older than vdsm-4.20 (or alternatively in clusterLevel < 4.2)

Comment 3 Michael Burman 2017-12-14 09:43:40 UTC
(In reply to Dan Kenigsberg from comment #1)
> We must not attempt to read LLDP information when the host is older than
> vdsm-4.20 (or alternatively in clusterLevel < 4.2)

vdsm-4.19.42-1.el7ev.x86_64 doesn't have the problem, it report the Lldp data.

Comment 4 Michael Burman 2018-01-08 07:28:31 UTC
Verified on - 4.2.1-0.2.el7

Comment 8 errata-xmlrpc 2018-05-15 17:46:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 9 Franta Kust 2019-05-16 13:08:35 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.