Bug 152544 - Dell D800 freezes when removing the CD-ROM drive
Dell D800 freezes when removing the CD-ROM drive
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Alan Cox
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 01:44 EST by Morten Green Hermansen
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-24 09:09:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Morten Green Hermansen 2005-03-30 01:44:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7.5) Gecko/20041221

Description of problem:
When I remove the CD-ROM drive (not a CD but the whole drive module) from the Dell D800 laptop the machine freezes. It can only be turned off by removing the bateries (or pressing the power button for 10 seconds).
The BIOS version of the laptop is A12.


Version-Release number of selected component (if applicable):
kernel-2.6.9-5.0.3.EL

How reproducible:
Always

Steps to Reproduce:
1. Start-up RHEL4
2. Remove the CD-ROM drive module
3. Wait for 1-2 seconds


Actual Results:  The computer is totally freezed (crashed). Cannot even change the state of the caps lock key.


Expected Results:  The computer should just continue working.

Additional info:
Comment 1 Dave Jones 2005-03-30 11:34:16 EST
how is the cdrom connected on this ? USB ? PCMCIA ? Docking bay ?
Comment 2 Morten Green Hermansen 2005-03-30 13:17:46 EST
The drive is connected through the docking bay. I cannot test other types of
drives, like floppy drives because this is the only one i got.
Inserting and ejection of batteries in the same port gives no problem.
Comment 3 Alan Cox 2005-04-24 09:09:03 EDT
Laptop specific IDE hotplug is not supported by Linux at this time. 

Note You need to log in before you can comment on or make changes to this bug.