Bug 1525596 - [REST] entrypoint for events returns Blank template element without href nor id
Summary: [REST] entrypoint for events returns Blank template element without href nor id
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.2.2
: ---
Assignee: Ori Liel
QA Contact: Radim Hrazdil
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-13 16:11 UTC by Gonza
Modified: 2019-05-16 13:05 UTC (History)
12 users (show)

Fixed In Version: ovirt-engine-4.2.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 17:46:56 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1488 0 None None None 2018-05-15 17:48:00 UTC
oVirt gerrit 86970 0 master MERGED restapi: Missing ID For Blank Template In Event 2018-02-13 12:21:22 UTC
oVirt gerrit 87561 0 ovirt-engine-4.2 MERGED restapi: Missing ID For Blank Template In Event 2018-02-14 08:45:09 UTC

Description Gonza 2017-12-13 16:11:18 UTC
Description of problem:
When accessing the events entrypoint (ovirt-engine/api/events), if one of the events is related to the Blank template, this element is returned with no href nor id.

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.0-0.6.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Access events entrypoint @ovirt-engine/api/events
2. Search for Blank template element
3. Check that nor href nor id is present in the element

Actual results:
<event href="..." id="...">
  ...
  <template>
    <name>Blank</name>
  </template>
  ...
</event>

Expected results:
<event href="..." id="...">
  ...
  <template href="/ovirt-engine/api/templates/00000000-0000-0000-0000-000000000000" id="00000000-0000-0000-0000-000000000000">
    <name>Blank</name>
  </template>
  ...
</event>


Additional info:
This is only occurring with the Blank template all other template elements are returned correctly

Comment 1 Juan Hernández 2017-12-13 17:02:57 UTC
Ori, can you take a look at this? And maybe assign to yourself?

I think that the problem is that the id of the blank template is all zeros, and we assume that that means that there is no template.

Comment 2 Yaniv Kaul 2017-12-17 11:49:22 UTC
severity?

Comment 3 Ori Liel 2017-12-25 07:45:30 UTC
Can you please provide an example of a flow, that will result in an event that relates to the blank template?

Comment 4 Gonza 2018-01-05 11:23:14 UTC
(In reply to Ori Liel from comment #3)
> Can you please provide an example of a flow, that will result in an event
> that relates to the blank template?

Same workflow as in original description with VM creation from Blank template.

Comment 5 Radim Hrazdil 2018-02-26 10:38:58 UTC
Verified that events related to Blank template have <template> element with both, href and id.

Version RHV 4.2.2

Comment 6 RHV bug bot 2018-03-16 15:03:10 UTC
INFO: Bug status (VERIFIED) wasn't changed but the folowing should be fixed:

[Tag 'ovirt-engine-4.2.2.4' doesn't contain patch 'https://gerrit.ovirt.org/87561']
gitweb: https://gerrit.ovirt.org/gitweb?p=ovirt-engine.git;a=shortlog;h=refs/tags/ovirt-engine-4.2.2.4

For more info please contact: rhv-devops@redhat.com

Comment 10 errata-xmlrpc 2018-05-15 17:46:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1488

Comment 11 Franta Kust 2019-05-16 13:05:23 UTC
BZ<2>Jira Resync


Note You need to log in before you can comment on or make changes to this bug.