Bug 152566 - nforce4 network issues
Summary: nforce4 network issues
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-30 14:01 UTC by Marco
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-06-21 17:17:43 UTC


Attachments (Terms of Use)
Yum, gnome's icon, ipconfig, ping, network conf and tool screenshot (170.84 KB, image/jpeg)
2005-03-30 14:01 UTC, Marco
no flags Details

Description Marco 2005-03-30 14:01:50 UTC
Description of problem:
I've a MSI K8N Platinum with nforce4 SLI.
I've a problem with the integrated network and forcedeth: my network seems
works, but as you can see in the attchment some programs say that network
doesn't work, others yes:
- ping to www.google.it works
- browser can reach www.google.it
- network configuration says that eth0 is ok and working

but

- gnome's network icon say no network device
- network tool say that eth0 is inactive.
- Yum sometimes reaches repos sometimes not.


Version-Release number of selected component (if applicable):
kernel version: 2.6.11-1.1208-x86_64


Actual results:
network works not very well.

Expected results:
network fully recognized by any component.

Comment 1 Marco 2005-03-30 14:01:51 UTC
Created attachment 112451 [details]
Yum, gnome's icon, ipconfig, ping, network conf and tool screenshot

Comment 2 Marco 2005-03-31 14:48:04 UTC
updated to kernel version: 2.6.11-1.1219-x86_64
same issues.

none that help me?

Comment 3 Marco 2005-04-03 13:36:46 UTC
updated to kernel version: 2.6.11-1.1225-x86_64
same issues.

I need a fix!

Comment 4 Marco 2005-04-12 13:46:56 UTC
updated to Fedora Core 4 test 2 with kernel version: 2.6.11-1.1226-x86_64
same issues.

I'm writing on a wall or someone will help me?

Comment 5 Marco 2005-04-12 14:05:41 UTC
finally tried to update to kernel version: 2.6.11-1.1236-x86_64
same issues.

Comment 6 Marco 2005-04-20 14:41:06 UTC
updated to kernel version: 2.6.11-1.1251-x86_64
same issues.

Comment 7 Marco 2005-04-26 13:39:26 UTC
updated to kernel version: 2.6.11-1.1267-x86_64
same issues.

Comment 8 Marco 2005-05-11 19:01:50 UTC
updated to Fedora Core 4 test 3 and kernel version: 2.6.11-1.1290-x86_64
same issues.

Comment 9 Marco 2005-06-21 10:54:41 UTC
updated to Fedora Core 4 final kernel version: 2.6.11-1.1369-x86_64
same issues.

So I've tried to install a PCI card, I've installed a VIA VT6105 PCI based
network card and SAME ISSUE.
- FF can reach network
- ping works

- yum doesn't work
- gnome's network icon show no network.

I think it's a Fedora's bug, because different network, different modules, same
issues.
Please FIX this or help me to have a normal situation.

Thanx

Comment 10 Dave Jones 2005-06-21 12:07:00 UTC
the fact that ping/browser works suggests the driver is fine, so my thinking is
that this must be a problem in the gui tools.

Comment 11 Harald Hoyer 2005-06-21 12:37:55 UTC
system-config-network says it is "active" !!!

Comment 12 Marco 2005-06-21 12:50:59 UTC
(In reply to comment #11)
> system-config-network says it is "active" !!!

yes it is, but can be that says it is active but forget to change something?

Comment 13 Dan Williams 2005-06-21 13:15:28 UTC
what is the output of (as root):

/sbin/mii-tool

and

/sbin/ethtool

?

Comment 14 Dan Williams 2005-06-21 13:39:26 UTC
That should be:

/sbin/mii-tool eth0
/sbin/ethtool eth0



Comment 15 Marco 2005-06-21 13:50:17 UTC
[root@b-52 ~]# /sbin/mii-tool eth0
eth0: negotiated 100baseTx-FD flow-control, link ok
[root@b-52 ~]# /sbin/ethtool eth0
Settings for eth0:
        Supported ports: [ TP MII ]
        Supported link modes:   10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Supports auto-negotiation: Yes
        Advertised link modes:  10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
        Advertised auto-negotiation: Yes
        Speed: 100Mb/s
        Duplex: Full
        Port: MII
        PHYAD: 1
        Transceiver: internal
        Auto-negotiation: on
        Supports Wake-on: pumbg
        Wake-on: d
        Current message level: 0x00000001 (1)
        Link detected: yes
[root@b-52 ~]#


Comment 16 Marco 2005-06-21 14:36:31 UTC
Changing back the hostname from b-52 to localhost.localdomain yum works!
gnome's network icon still not working.

??

Comment 17 Marco 2005-06-21 15:20:02 UTC
Abstract:
I've a _fresh_ Fedora Core 4 final version installed.
I've changed the default network configuration -> dns -> hostname from
"localhost.localdomain" to "b-52" and yum stop working.
Browser and ping work.
Switching to another network (from integreted nforce4 to VIA VT6105) same results.

Backing to "localhost.localdomain" let yum to work.


Comment 18 Marco 2005-06-21 15:27:51 UTC
when I say yum stop working I want to say that cannot reach repositary, it stops
like in the image attached.
The only way is to hit ctrl-c and terminate the process.

Comment 19 Marco 2005-06-21 17:17:43 UTC
Ok now yum works, don't know why, also with b-52 hostname, it is very slow on
retrieve informations about repositaries, but it works.
Gnome's network icon works after entering eht0 as I have read here
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=161216


Note You need to log in before you can comment on or make changes to this bug.