Bug 1525729 - Specifying KeystoneRegion does not properly configure the region name in all deployed services
Summary: Specifying KeystoneRegion does not properly configure the region name in all ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: David Peacock
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks: 1533994 1533999 1534002
TreeView+ depends on / blocked
 
Reported: 2017-12-13 23:27 UTC by Alex Schultz
Modified: 2018-06-27 13:41 UTC (History)
3 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1533994 1533999 1534002 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:40:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 532255 None MERGED Correct panko auth region 2020-06-18 01:11:54 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:41:00 UTC

Description Alex Schultz 2017-12-13 23:27:04 UTC
Description of problem:
We expose the ability to customize the Keystone region name but it is not being correctly used for all services. Additionally there are instances of RegionOne (the upstream default for this) within the configuration files of deployed services.

Version-Release number of selected component (if applicable):
openstack-tripleo-validations-5.1.2-1.el7ost.noarch
openstack-tripleo-puppet-elements-5.3.2-1.el7ost.noarch
openstack-tripleo-image-elements-5.3.1-1.el7ost.noarch
python-tripleoclient-5.4.3-1.el7ost.noarch
openstack-tripleo-0.0.8-0.2.4de13b3git.el7ost.noarch
puppet-tripleo-5.6.4-2.el7ost.noarch
openstack-tripleo-ui-1.2.1-1.el7ost.noarch
openstack-tripleo-heat-templates-5.3.3-1.el7ost.noarch
openstack-tripleo-common-5.4.4-1.el7ost.noarch


How reproducible:
always

Steps to Reproduce:
1. Deploy overcloud with the following environment file:

parameter_defaults:
  KeystoneRegion: 'foo'

2. Inspect configurations for incorrect region_name settings
3.

Actual results:

[root@overcloud-controller-0 ~]# grep regionOne -ir /etc
/etc/saf/enabler_conf.ini:#region_name = RegionOne
/etc/nova/nova.conf:region_name=RegionOne
/etc/neutron/neutron_lbaas.conf:#region = RegionOne
/etc/aodh/aodh.conf:region_name = regionOne
/etc/puppet/hieradata/service_configs.yaml:aodh::auth::auth_region: regionOne
/etc/glance/glance-cache.conf:os_region_name=RegionOne
/etc/glance/glance-api.conf:os_region_name=RegionOne

[root@overcloud-compute-0 ~]# grep regionOne -ir /etc
/etc/saf/enabler_conf.ini:#region_name = RegionOne
/etc/nova/nova.conf:region_name=RegionOne
/etc/neutron/neutron_lbaas.conf:#region = RegionOne

Expected results:

region_name should match KeystoneRegion


Additional info:

Comment 1 David Peacock 2018-01-08 23:26:31 UTC
Reproduced this, with slightly differing results on my env.

Controller:

/etc/trove/trove-taskmanager.conf:#os_region_name = RegionOne
/etc/trove/trove.conf:#os_region_name = RegionOne
/etc/barbican/barbican-functional.conf:#region_name=RegionOne

[... keystone catalog entries snipped]

/etc/nova/nova.conf:#region_name=RegionOne
/etc/neutron/neutron_lbaas.conf:#region = RegionOne
/etc/skydive/skydive.yml:  region_name: RegionOne
/etc/puppet/hieradata/service_configs.json:    "panko::auth::auth_region": "regionOne",

Compute:

/etc/trove/trove-taskmanager.conf:#os_region_name = RegionOne
/etc/trove/trove.conf:#os_region_name = RegionOne
/etc/barbican/barbican-functional.conf:#region_name=RegionOne

[... keystone catalog entries snipped]

/etc/nova/nova.conf:#region_name=RegionOne
/etc/neutron/neutron_lbaas.conf:#region = RegionOne
/etc/openstack-dashboard/local_settings:#    OPENSTACK_KEYSTONE_URL: 'RegionOne'
/etc/skydive/skydive.yml:  region_name: RegionOne

Comment 2 David Peacock 2018-01-09 00:07:24 UTC
Controller most concern:

/etc/skydive/skydive.yml:  region_name: RegionOne
/etc/puppet/hieradata/service_configs.json:    "panko::auth::auth_region": "regionOne",

Compute most concern:

/etc/skydive/skydive.yml:  region_name: RegionOne

Comment 3 David Peacock 2018-01-09 17:11:19 UTC
Patch for the panko auth region aspect submitted upstream for review.  Once this has been merged, I'll proceed with downstream backports for panko auth and nova.

https://review.openstack.org/532255

Comment 4 David Peacock 2018-01-11 16:09:29 UTC
Upstream patch merged.

Currently proceeding to reproduce downstream.  RHOSP12 first, then I'll go down the version order to 10.

Comment 8 Gurenko Alex 2018-05-03 08:27:05 UTC
 Verified on puddle 2018-05-01.6. Region name successfully applies to the configurations.

Comment 10 errata-xmlrpc 2018-06-27 13:40:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.