Bug 1525850 - rdma transport may access an obsolete item in gf_rdma_device_t->all_mr, and causes glusterfsd/glusterfs process crash.
Summary: rdma transport may access an obsolete item in gf_rdma_device_t->all_mr, and c...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rdma
Version: 3.12
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1522651
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-14 08:10 UTC by Mohammed Rafi KC
Modified: 2018-02-01 04:43 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.12.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1522651
Environment:
Last Closed: 2018-02-01 04:43:00 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-12-14 08:13:13 UTC
REVIEW: https://review.gluster.org/19032 (rpc-transport/rdma: Add a mutex for the list of RDMA Memory Region(MR) access) posted (#2) for review on release-3.12 by mohammed rafi  kc

Comment 2 Worker Ant 2018-01-02 09:51:12 UTC
COMMIT: https://review.gluster.org/19032 committed in release-3.12 by \"Yi Wang\" <wangyi8848@gmail.com> with a commit message- rpc-transport/rdma: Add a mutex for the list of RDMA Memory Region(MR) access

Problem: gf_rdma_device_t->all_mr is a __gf_rdma_arena_mr(includes MR content)
	 kind of list in the rdma rpc-transport. The rdma rpc-transport will
	 add/delete items to the list when MRs register, deregister, and free.
	 Because gf_rdma_device_t->all_mr is used by different threads
	 and it is not mutex protected, rdma transport maybe access obsolete
	 items in it.

Solution: Add a mutex protection for the gf_rdma_device_t->all_mr.

> Change-Id: I2b7de0f7aa516b90bb6f3c6aae3aadd23b243900
> BUG: 1522651
> Signed-off-by: Yi Wang <wangyi@storswift.com>

(cherry picked from commit 8483ed87165c1695b513e223549d33d2d63891d9)
Change-Id: I2b7de0f7aa516b90bb6f3c6aae3aadd23b243900
BUG: 1525850
Signed-off-by: Yi Wang <wangyi@storswift.com>

Comment 3 Jiffin 2018-02-01 04:43:00 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.5, please open a new bug report.

glusterfs-3.12.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-devel/2018-February/054356.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.