Bug 152586 - netconsole removal segfault after initialisation failure
netconsole removal segfault after initialisation failure
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 10:11 EST by Richard Kennedy
Modified: 2015-01-04 17:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-29 21:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Kennedy 2005-03-30 10:11:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.6) Gecko/20050323 Firefox/1.0.2 Fedora/1.0.2-1.3.1

Description of problem:
Atempting to use netconsole on a jvc laptop.
netconsole init fails
>kernel: netconsole: eth0 doesn't support polling, abort ing.

Then running /sbin/modprobe -r netconsole produces a segfault.


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.770_FC3

How reproducible:
Always

Steps to Reproduce:
1. modprobe netconsole
2. (netconsole init fails)
3. modprobe -r netconsole
  

Actual Results:  seg fault

Expected Results:  netconsole module removed cleanly.

Additional info:

Mar 30 14:11:53 mininote kernel: Unable to handle kernel NULL pointer dereference at virtual address 000 00188
Mar 30 14:11:53 mininote kernel:  printing eip:
Mar 30 14:11:53 mininote kernel: c02b2fe4
Mar 30 14:11:53 mininote kernel: *pde = 00000000
Mar 30 14:11:53 mininote kernel: Oops: 0002 [#1]
Mar 30 14:11:53 mininote kernel: Modules linked in: netconsole sis parport_pc lp parport autofs4 sunrpc pcmcia ipt_REJECT ipt_state ip_conntrack iptable_filter ip_tables vfat fat video button battery asus_acp i ac md5 ipv6 ohci1394 ieee1394 joydev yenta_socket pcmcia_core ohci_hcd ehci_hcd i2c_sis630 i2c_core sn d_intel8x0m snd_trident snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc gamepo rt snd_util_mem snd_mpu401_uart snd_rawmidi snd_seq_device snd soundcore prism2_usb(U) p80211(U) sis900 dm_snapshot dm_zero dm_mirror ext3 jbd dm_mod
Mar 30 14:11:53 mininote kernel: CPU:    0
Mar 30 14:11:53 mininote kernel: EIP:    0060:[<c02b2fe4>]    Not tainted VLI
Mar 30 14:11:53 mininote kernel: EFLAGS: 00010246   (2.6.10-1.770_FC3)
Mar 30 14:11:53 mininote kernel: EIP is at netpoll_cleanup+0x141/0x150
Mar 30 14:11:53 mininote kernel: eax: 00000000   ebx: cfb39cc0   ecx: 00000246   edx: 0000990e
Mar 30 14:11:53 mininote kernel: esi: 00000000   edi: 09623608   ebp: c0f09000   esp: c0f09f64
Mar 30 14:11:53 mininote kernel: ds: 007b   es: 007b   ss: 0068
Mar 30 14:11:53 mininote kernel: Process modprobe (pid: 5621, threadinfo=c0f09000 task=c5ef1220)
Mar 30 14:11:53 mininote kernel: Stack: cfb3a200 00000000 cfb3925a c01357b8 00000000 6374656e 6f736e6f 0 000656c
Mar 30 14:11:53 mininote kernel:        c5db5060 b7f37000 b7f38000 c0152bbb c5db5060 c0ee57b0 c0152f7e c 0ee5d44
Mar 30 14:11:53 mininote kernel:        c5db5060 c5db5090 00000000 006230a8 00000000 09623608 00000000 c 0103443
Mar 30 14:11:53 mininote kernel: Call Trace:
Mar 30 14:11:53 mininote kernel:  [<cfb3925a>] cleanup_netconsole+0x1d/0x33 [netconsole]
Mar 30 14:11:53 mininote kernel:  [<c01357b8>] sys_delete_module+0x125/0x15d
Mar 30 14:11:53 mininote kernel:  [<c0152bbb>] unmap_vma_list+0xe/0x17
Mar 30 14:11:53 mininote kernel:  [<c0152f7e>] do_munmap+0x1dc/0x1e6
Mar 30 14:11:53 mininote kernel:  [<c0103443>] syscall_call+0x7/0xb
Mar 30 14:11:53 mininote kernel: Code: 11 33 c0 68 9f 89 30 c0 e8 fd 7f e6 ff c7 05 e0 32 37 c0 00 00 00  00 56 9d 8b 03 85 c0 74 0a c7 80 04 02 00 00 00 00 00 00 8b 03 <ff> 88 88 01 00 00 c7 03 00 00 00 00 5b  5e c3 a1 88 a6 41 c0 c3
Comment 1 Richard Kennedy 2005-03-30 10:15:08 EST
cleanup_netconsole calls dev_put(np->dev) 
np->dev still null? not set due to the init failure?
Comment 2 Dave Jones 2005-07-15 15:28:35 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Richard Kennedy 2005-07-18 08:53:36 EDT
Running on the latest FC4 & 2.6.12-1.1398.
I no longer see the netconsole init failing and the module unload is working
correctly. Thanks for you help!.

Now, I don't seem to be getting any output from netconsole but maybe that's a
config or firewall/SELinux issue.
But, the unload bug is fixed. 

Thanks
Richard

Comment 4 Dave Jones 2005-08-26 02:06:42 EDT
It was temporarily disabled when I rebased to 2.6.12, and never fixed up.
I've just done this for the next build.

Note You need to log in before you can comment on or make changes to this bug.