Bug 1525883 - [ALL_LANG] CFME SSUI My Orders - Oder page has untranslated entries
Summary: [ALL_LANG] CFME SSUI My Orders - Oder page has untranslated entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service
Version: 5.9.0
Hardware: x86_64
OS: All
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Allen W
QA Contact: Krishna Babu K
URL:
Whiteboard:
Depends On:
Blocks: 1553475
TreeView+ depends on / blocked
 
Reported: 2017-12-14 10:08 UTC by Krishna Babu K
Modified: 2019-08-06 20:05 UTC (History)
7 users (show)

Fixed In Version: 5.10.0.28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1553475 (view as bug list)
Environment:
Last Closed: 2019-02-07 23:00:45 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
cfme ssui My orders - order page (100.07 KB, image/png)
2017-12-14 10:08 UTC, Krishna Babu K
no flags Details
Soooooooo bad news, most of the untranslated text is provided by the server (614.73 KB, image/png)
2017-12-14 16:13 UTC, Allen W
no flags Details
Translations still not present, verified on 5.10.0.24.20181113213923_03b81fd (80.51 KB, image/png)
2018-11-24 14:55 UTC, Krishna Babu K
no flags Details
Translation for order is now present. (78.77 KB, image/png)
2018-12-11 10:41 UTC, Krishna Babu K
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:0212 None None None 2019-02-07 23:00:51 UTC

Description Krishna Babu K 2017-12-14 10:08:28 UTC
Created attachment 1367903 [details]
cfme ssui My orders - order page

Description of problem:
Please refer attached screen-shot

Version-Release number of selected component (if applicable):
5.9.0.13.20171212214416_f4f190a

How reproducible:
Always

Steps to Reproduce:
1. Log into cfme ssui with non en_US locale
2. Navigate to My Orders
3. Click on any order, following page has most of the content in English.

Actual results:
Translations not present

Expected results:
Please mark these entries to get them translated, if not already.

Additional info:
Please refer attached screen-shot

Comment 2 Allen W 2017-12-14 16:13:05 UTC
Created attachment 1368077 [details]
Soooooooo bad news, most of the untranslated text is provided by the server

But we can translate a few strings, will throw up a pr for that shortly

Comment 3 Allen W 2017-12-14 16:30:00 UTC
We could opt to not use the order name, but then if the user names the order, we would be kinda in a bad place, not showing the named order :-/ here is a pr that does update the one untagged element: 
https://github.com/ManageIQ/manageiq-ui-service/pull/1344

Comment 5 Krishna Babu K 2018-11-24 14:55:05 UTC
Created attachment 1508375 [details]
Translations still not present, verified on 5.10.0.24.20181113213923_03b81fd

Comment 7 Allen W 2018-11-26 13:48:04 UTC
Krishna, any chance you can provide the ip of a machine that exhibits this issue?

Comment 8 Krishna Babu K 2018-11-27 15:23:33 UTC
Hi Allen,
Yes, https://10.65.207.1/ 

thanks,
Krishna.

Comment 9 Allen W 2018-11-27 17:51:38 UTC
https://github.com/ManageIQ/manageiq-ui-service/pull/1500

and here's the pr

Comment 10 Allen W 2018-11-28 15:37:15 UTC
Pr was merged!

Comment 11 CFME Bot 2018-12-03 15:21:54 UTC
New commit detected on ManageIQ/manageiq-ui-service/hammer:

https://github.com/ManageIQ/manageiq-ui-service/commit/e7e33b5c18b8d7067dc0867b969d525820c96efd
commit e7e33b5c18b8d7067dc0867b969d525820c96efd
Author:     Martin Hradil <himdel@seznam.cz>
AuthorDate: Wed Nov 28 10:24:37 2018 -0500
Commit:     Martin Hradil <himdel@seznam.cz>
CommitDate: Wed Nov 28 10:24:37 2018 -0500

    Merge pull request #1500 from AllenBW/BZ/#1525883-untranslated-order-strings

     BZ#1525883 CFME SSUI My Orders - Oder page has untranslated entries

    (cherry picked from commit f5fa74db18edad1ba5b806ec99d49f66c2768358)

    Fixes https://bugzilla.redhat.com/show_bug.cgi?id=1525883

 client/app/states/orders/details/details.html | 4 +-
 client/app/states/orders/details/details.state.js | 3 -
 client/app/states/orders/details/details.state.spec.js | 2 +-
 3 files changed, 3 insertions(+), 6 deletions(-)

Comment 12 Krishna Babu K 2018-12-11 10:41:35 UTC
Created attachment 1513331 [details]
Translation for order is now present.

Comment 13 Krishna Babu K 2018-12-11 10:44:10 UTC
Verified on 5.10.0.28.20181204160308_aa3b074
Translation for Order is now present. 
Translation not present for Provisioning Service and Pending_approval.
Based on Comment 12 and Comment 2 Changing status to Verified.

Comment 14 errata-xmlrpc 2019-02-07 23:00:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:0212


Note You need to log in before you can comment on or make changes to this bug.