Bug 152591 - ERROR: relation "pg_catalog.pg_user" does not exist (Can't use any \d commands)
ERROR: relation "pg_catalog.pg_user" does not exist (Can't use any \d commands)
Status: CLOSED DUPLICATE of bug 149237
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postgresql (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Lane
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 10:54 EST by Max Kanat-Alexander
Modified: 2013-07-02 23:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 13:15:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Kanat-Alexander 2005-03-30 10:54:34 EST
I'm running RHEL4, and I just downloaded postgresql-server-7.4.7-2.RHEL4.1
today. I started it, it init'ed the DB, and everything seemed fine.

I did an "su - postgres", created a database with createdb, and connected to it
using "psql <db_name>".

When I try to use any \d command that would tell me anything about a table, I
get the error:

ERROR:  relation "pg_catalog.pg_user" does not exist
Comment 1 Max Kanat-Alexander 2005-03-30 12:04:29 EST
OK, I've managed to repair the issue locally, here's the steps I took that I
*think* fixed it (I did a few other things, too, but I think they were mostly a
no-op):

service postgresql stop
rm -rf /var/lib/pgsql/data
mkdir /var/lib/pgsql/data
chmod go-rwx /var/lib/pgsql/data
restorecon /var/lib/pgsql/data
setenforce 0
su - postgres
initdb
exit
service postgresql start
service postgresql stop
setenforce 1
service postgresql start

I'm not sure that the last little bit of doing the first start before turning
back on SELinux is necessary.
Comment 2 Tom Lane 2005-03-30 13:15:05 EST
Yeah, this sounds exactly like bug #149237.  I believe this is fixed (or more
accurately, worked around) as of postgresql-7.4.7-3.RHEL4.1.

See also bug #143208

*** This bug has been marked as a duplicate of 149237 ***
Comment 3 Terry Polzin 2005-05-17 16:30:05 EDT
OK so where is postgresql-7.4.7-3.RHEL4.1?  It's not in the errata

Note You need to log in before you can comment on or make changes to this bug.