Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1525963 - Fedora Kerberos account can't be added
Fedora Kerberos account can't be added
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-online-accounts (Show other bugs)
7.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-12-14 08:59 EST by Matěj Cepl
Modified: 2018-05-17 10:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: gnome-online-accounts-3.26.2-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 09:08:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 789187 None None None 2017-12-14 08:59 EST
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 09:09 EDT

  None (edit)
Description Matěj Cepl 2017-12-14 08:59:19 EST
Description of problem:
This is bascially for introducing https://bugzilla.gnome.org/show_bug.cgi?id=789187 into RHEL 7.5

Version-Release number of selected component (if applicable):
gnome-online-accounts-3.26.1-2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. try to add account mcepl@FEDORAPROJECT.ORG Kerberos principal to GOA
2.
3.

Actual results:
It timeouts, with journalctl log containing

Dec 14 14:32:04 mitmanek.ceplovi.cz realmd[27973]: Resolving fedoraproject.org failed: No DNS record of the requested type for “_kerberos._udp.fedoraproject.org”
Dec 14 14:32:04 mitmanek.ceplovi.cz realmd[27973]: No DNS record of the requested type for “_ldap._tcp.fedoraproject.org”

Expected results:
collecting necessary information from DNS SRV record for _kerberos._tcp.fedoraproject.org
Comment 2 Debarshi Ray 2017-12-19 09:14:30 EST
I built gnome-online-accounts-3.26.2-1.el7:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14818471
Comment 4 Matěj Cepl 2017-12-19 15:05:33 EST
(In reply to Debarshi Ray from comment #2)
> I built gnome-online-accounts-3.26.2-1.el7:
> https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=14818471

With this package (and don't forget to pkill -f goa- ) I can add my FEDORAPPROJECT.ORG principal to GOA. Thank you.
Comment 8 errata-xmlrpc 2018-04-10 09:08:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.