Bug 1525969 - Unicode decode error when downloading the volume transfer authorization information
Summary: Unicode decode error when downloading the volume transfer authorization infor...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: beta
: 13.0 (Queens)
Assignee: Radomir Dopieralski
QA Contact: Beth White
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-12-14 14:06 UTC by Chen
Modified: 2018-06-27 13:41 UTC (History)
4 users (show)

Fixed In Version: python-django-horizon-13.0.1-0.20180323102048.4dd4ef0.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:40:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1742412 None None None 2018-01-10 10:10:44 UTC
OpenStack gerrit 532488 None master: MERGED horizon: Handle unicode when downloading transfer credentials (I2051e80b74b42c1817c0992f8a52ffe96b3cabc8) 2018-03-29 15:59:54 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:41:00 UTC

Description Chen 2017-12-14 14:06:38 UTC
Description of problem:

Unicode decode error when downloading the volume transfer authorization information

Version-Release number of selected component (if applicable):

OSP10
Japanese language dashboard

How reproducible:

100%

Steps to Reproduce:
1. Switch the language to Japanese in dashboard
2. Create transfer in volume
3. Download the authorization information

Actual results:

The following error will be output in horizon.log and the authorization information can not be downloaded

UnicodeDecodeError: 'ascii' codec can't decode byte 0xe8 in position 0: ordinal not in range(128)


Expected results:


Additional info:

Comment 8 errata-xmlrpc 2018-06-27 13:40:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.