Bug 152609 - telnet escape character '^]' does not function
telnet escape character '^]' does not function
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-30 14:08 EST by Aaron VanDevender
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.12.0-1.fc5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-23 00:46:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aaron VanDevender 2005-03-30 14:08:36 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
telnet to any unix port and you get the message "Escape character is '^]'." However, actually pressing the escape character produces no effect. This is probably mismatch between somethig in telnet and something in termcap.

Version-Release number of selected component (if applicable):
telnet-0.17-26.2 termcap-11.0.1-17

How reproducible:
Always

Steps to Reproduce:
1.telnet localhost 25
2.press '^]'


Actual Results:  No effect.

Expected Results:  a "telnet>" session prompt should have appeared.

Additional info:

I'm running gnome-terminal, bash, and TERM=xterm. (i.e., the defaults)
Comment 1 Harald Hoyer 2005-04-01 09:02:59 EST
could you try other terminals like xterm and konsole?
Comment 2 Aaron VanDevender 2005-04-01 09:49:33 EST
I tried it in xterm, aterm, rxvt and the virtual console. It works correctly in
all of them, so it seems to be isolated to gnome-terminal.
Comment 3 Harald Hoyer 2005-04-01 11:43:23 EST
maybe you messed up the settings?
Comment 4 Aaron VanDevender 2005-04-01 12:59:38 EST
I've seen this on multiple computers, so it's not the settings for my machine.
I've screwed around with some virgin machines and the trick is that you need to
have the gnome keyboard indicator applet running. If you load the applet, then
switch to another keymap (eg, Dvorak) then it breaks ^]. Switching the layout
back to USA doesn't fix the problem. It remains broken, even if you remove the
applet from the gnome-panel; logout; restart X (ctl-alt-backspace); and log back
in. Whatever you do, once you switch layouts to Dvorak, your gnome-terminal ^]
is permanently hosed.

I'm not sure if this is a gnome-keyboard-indicator or a gnome-terminal bug
becasue it only seems to happen to gnome-terminal (not rxvt) but it also only
happens when the keyboard indicator is running.
Comment 5 Daniel Roesen 2005-05-14 19:07:17 EDT
I'm seeing the same problem in a freshly installed FC4test3 gnome-terminal,
without any keyboad layout switching or anything.
Comment 6 Daniel Roesen 2005-06-04 18:48:57 EDT
Harald... is this actually a gnome-terminal, or a vte problem?
Comment 7 Ray Strode [halfline] 2005-06-06 10:26:01 EDT
Daniel, probably vte.
Comment 8 Daniel Roesen 2005-06-06 10:35:58 EDT
Well, then I guess we should re-assign to vte.
Comment 9 Ray Strode [halfline] 2005-06-06 10:41:45 EDT
Yea, that's what I meant to do.  I hit the wrong radio button or something.
Comment 10 Aaron VanDevender 2006-03-23 00:46:18 EST
This is fixed in FC5, so I'm closing the bug.

Note You need to log in before you can comment on or make changes to this bug.